Click or drag to resize

IntersectionEvent Class

Provides all the information for a single Curve Intersection event.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.IntersectIntersectionEvent

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class IntersectionEvent

The IntersectionEvent type exposes the following members.

Constructors
  NameDescription
Public methodIntersectionEvent
Initializes a new instance of the IntersectionEvent class
Top
Properties
  NameDescription
Public propertyCode exampleIsOverlap
All curve intersection events are either a single point or an overlap.
Public propertyIsPoint
All curve intersection events are either a single point or an overlap.
Public propertyOverlapA
Gets the interval on curve A where the overlap occurs. If the intersection type is not overlap, this value is meaningless.
Public propertyOverlapB
Gets the interval on curve B where the overlap occurs. If the intersection type is not overlap, this value is meaningless.
Public propertyParameterA
Gets the parameter on Curve A where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyParameterB
Gets the parameter on Curve B where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyPointA
Gets the point on Curve A where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyPointA2
Gets the end point of the overlap on Curve A. If the intersection type is not overlap, this value is meaningless.
Public propertyPointB
Gets the point on Curve B (or Surface B) where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyPointB2
Gets the end point of the overlap on Curve B (or Surface B). If the intersection type is not overlap, this value is meaningless.
Top
Methods
  NameDescription
Public methodStatic memberCompareEquivalent(IntersectionEvent, IntersectionEvent, Double)
Compare intersection events.
Public methodStatic memberCompareEquivalent(IntersectionEvent, IntersectionEvent, Double, TextLog)
Compare intersection events.
Public methodSurfaceOverlapParameter
If this instance records a Curve|Surface intersection event, and the intersection type if overlap, then use this function to get the U and V domains on the surface where the overlap occurs.
Public methodSurfacePointParameter
If this instance records a Curve|Surface intersection event, and the intersection type is point, then use this function to get the U and V parameters on the surface where the intersection occurs.
Top
See Also