Click or drag to resize

IntersectionEventCompareEquivalent Method (IntersectionEvent, IntersectionEvent, Double)

Compare intersection events.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public static bool CompareEquivalent(
	IntersectionEvent eventA,
	IntersectionEvent eventB,
	double relativePointTolerance
)

Parameters

eventA
Type: Rhino.Geometry.IntersectIntersectionEvent
The first intersection event to compare.
eventB
Type: Rhino.Geometry.IntersectIntersectionEvent
The second intersection event to compare.
relativePointTolerance
Type: SystemDouble
The comparison tolerance. If RhinoMath.UnsetValue, then RhinoMath.SqrtEpsilon is used.

Return Value

Type: Boolean
true if the two inputs represent the same intersection, false otherwise.
See Also