Click or drag to resize

IntersectionEvent Properties

The IntersectionEvent type exposes the following members.

Properties
  NameDescription
Public propertyCode exampleIsOverlap
All curve intersection events are either a single point or an overlap.
Public propertyIsPoint
All curve intersection events are either a single point or an overlap.
Public propertyOverlapA
Gets the interval on curve A where the overlap occurs. If the intersection type is not overlap, this value is meaningless.
Public propertyOverlapB
Gets the interval on curve B where the overlap occurs. If the intersection type is not overlap, this value is meaningless.
Public propertyParameterA
Gets the parameter on Curve A where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyParameterB
Gets the parameter on Curve B where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyPointA
Gets the point on Curve A where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyPointA2
Gets the end point of the overlap on Curve A. If the intersection type is not overlap, this value is meaningless.
Public propertyPointB
Gets the point on Curve B (or Surface B) where the intersection occurred. If the intersection type is overlap, then this will return the start of the overlap region.
Public propertyPointB2
Gets the end point of the overlap on Curve B (or Surface B). If the intersection type is not overlap, this value is meaningless.
Top
See Also