IntersectionCurveSelf Method |
Finds the places where a curve intersects itself.
Namespace:
Rhino.Geometry.Intersect
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static CurveIntersections CurveSelf(
Curve curve,
double tolerance
)
Public Shared Function CurveSelf (
curve As Curve,
tolerance As Double
) As CurveIntersections
Parameters
- curve
- Type: Rhino.GeometryCurve
Curve for self-intersections. - tolerance
- Type: SystemDouble
Intersection tolerance. If the curve approaches itself to within tolerance,
an intersection is assumed.
Return Value
Type:
CurveIntersectionsA collection of intersection events.
See Also