Param_AnnotationUnitsSettings Class |
Namespace: Grasshopper.Rhinoceros.Annotations.Params
The Param_AnnotationUnitsSettings type exposes the following members.
Name | Description | |
---|---|---|
Param_AnnotationUnitsSettings | Initializes a new instance of the Param_AnnotationUnitsSettings class |
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes that are associated with this object.
HasProxySources |
Gets a value indicating whether or not this parameter maintains proxy sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
IconCapableUI |
By default the NickName menu item supports the Icon Mode override toggle.
If your UI is not capable of displaying icons, then override this property
IsPrincipal |
Gets whether this parameter is a principal parameter.
Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
Obsolete |
Gets whether this object is obsolete. Default implementation returns true if
the class name contains the string "OBSOLETE" or if this class has been decorated with the
Optional |
Gets or sets whether or not this parameter is considered optional by the owner component.
ProxySourceCount |
Gets the number of proxy sources for this parameter.
Proxy sources are used during file IO, when actual sources might not be available yet.
Recipients |
Gets a list of all the recipients of this parameter.
I.e. a recipient has this parameter as one of the sources.
The Recipient list is maintained by the parameter,
Sources |
Gets a list of source parameters. Do not modify this list,
if you wish to add or remove sources, use dedicated functions
StateTags |
Gets all the StateTags that are associated with this parameter.
WireDisplay |
Gets or sets the wire display style for this parameter.
Name | Description | |
---|---|---|
AddRuntimeMessage |
Add a new message to this object. Valid message type flags are Warning and Error.
AddSource(IGH_Param) |
Append a new Source parameter to the end of the Sources list.
AddSource(IGH_Param, Int32) |
Insert a new Source parameter into the Sources list.
AppendAdditionalMenuItems |
Override this function if you want to add specific items to the object context menu
Default items already included in the menu toolstrip are:
1. Name
2. Preview
3. Warnings
AppendMenuItems |
This function is called when a context menu is about to be displayed.
Override it to set custom items. GH_ActiveObject will already populate
the menu with default items, if you merely wish to insert object-specific
ExpirePreview |
Call this function when you suspect that the preview has expired for this object.
ExpireSolution |
Informs the document that owns this object that the solution has expired.
The current object will be set to BLANK as a result. This method is recursive,
it will also expire any and all objects which depend on this object.
If you want a less destructive expiration, consider using ClearData().
MovedBetweenDocuments |
This method will be called when an object is moved from one document to another.
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
OnPingDocument |
Raise the PingDocument Event on the toplevel object and try to find
OnSolutionExpired |
Raises the SolutionExpired event on the toplevel object.
ReadFull |
GH_InstanceDescription does not by default serialize all fields.
Use this function to read all fields from the archive.
RelinkProxySources |
Attempt to replace all proxy sources with real sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
RemovedFromDocument |
This method will be called when an object is removed from a document.
RemoveEffects |
Remove all post-process effects. Note to implementors,
ReplaceSource(Guid, IGH_Param) |
Replace an existing source with a new one. If the old_source
ReplaceSource(IGH_Param, IGH_Param) |
Replace an existing source with a new one. If the old_source
WriteFull |
GH_InstanceDescription does not by default serialize all fields.
Use this function to write all fields to the archive.
Name | Description | |
---|---|---|