Param_AnnotationUnitsSettings Methods |
The Param_AnnotationUnitsSettings type exposes the following members.
Name | Description | |
---|---|---|
AddRuntimeMessage |
Add a new message to this object. Valid message type flags are Warning and Error.
AddSource(IGH_Param) |
Append a new Source parameter to the end of the Sources list.
AddSource(IGH_Param, Int32) |
Insert a new Source parameter into the Sources list.
AppendAdditionalMenuItems |
Override this function if you want to add specific items to the object context menu
Default items already included in the menu toolstrip are:
1. Name
2. Preview
3. Warnings
AppendMenuItems |
This function is called when a context menu is about to be displayed.
Override it to set custom items. GH_ActiveObject will already populate
the menu with default items, if you merely wish to insert object-specific
ExpirePreview |
Call this function when you suspect that the preview has expired for this object.
ExpireSolution |
Informs the document that owns this object that the solution has expired.
The current object will be set to BLANK as a result. This method is recursive,
it will also expire any and all objects which depend on this object.
If you want a less destructive expiration, consider using ClearData().
MovedBetweenDocuments |
This method will be called when an object is moved from one document to another.
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
OnPingDocument |
Raise the PingDocument Event on the toplevel object and try to find
OnSolutionExpired |
Raises the SolutionExpired event on the toplevel object.
ReadFull |
GH_InstanceDescription does not by default serialize all fields.
Use this function to read all fields from the archive.
RelinkProxySources |
Attempt to replace all proxy sources with real sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
RemovedFromDocument |
This method will be called when an object is removed from a document.
RemoveEffects |
Remove all post-process effects. Note to implementors,
ReplaceSource(Guid, IGH_Param) |
Replace an existing source with a new one. If the old_source
ReplaceSource(IGH_Param, IGH_Param) |
Replace an existing source with a new one. If the old_source
WriteFull |
GH_InstanceDescription does not by default serialize all fields.
Use this function to write all fields to the archive.