Click or drag to resize

RhinoApp Class

.NET RhinoApp is parallel to C++ CRhinoApp.
Inheritance Hierarchy
SystemObject
  RhinoRhinoApp

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class RhinoApp

The RhinoApp type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberBuildDate
Gets the build date.
Public propertyStatic memberCanSave
Returns true when Rhino is allowed to save, false otherwise Conditions where Rhino is not allowed to save are: when evaluation licenses are expired; when a Cloud Zoo lease is expired; when a license is shared by a single user on multiple computers, and the current computer is not active.
Public propertyStatic memberCheckNewObject
Returns true if Rhino will validate each object added to the document. This can be time consuming but is valuable for debugging.
Public propertyStatic memberCommandHistoryWindowText
Text in Rhino's command history window.
Public propertyStatic memberCommandLineOut
Provides a TextWriter that can write to the command line.
Public propertyStatic memberCommandPrompt
Rhino command prompt.
Public propertyStatic memberCommandWindowCaptureEnabled
Enable or disable capturing of the strings sent to the CommandWindow through Write and WriteLine calls
Public propertyStatic memberCurrentRhinoId
Gets the current ID of Rhino.
Public propertyStatic memberDaysUntilExpiration
Returns number of days until license expires. Zero when license is expired. Raises InvalidLicenseTypeException if LicenseExpires would return false.
Public propertyStatic memberDefaultUiFont
Default font used to render user interface
Public propertyStatic memberExeServiceRelease
Service release version of Rhino executable (0, 1, 2, ...) The integer is the service release number of Rhino. For example, this function returns "0" if Rhino V4SR0 is running and returns "1" if Rhino V4SR1 is running.
Public propertyStatic memberExeVersion
Major version of Rhino executable 4, 5, ...
Public propertyStatic memberInCommand
Gets the nested command count.
Public propertyStatic memberInstallationType
Gets the product installation type, as seen in Rhino's ABOUT dialog box.
Public propertyStatic memberInstallationTypeString
Gets the type of installation (product edition) of the license or lease.
Public propertyStatic memberInvokeRequired
Returns true if we are currently not running on the main user interface thread
Public propertyStatic memberIsClosing
Returns true if Rhino is in the process of closing, false otherwise. This can be true even before the Closing event fires, such as when RhinoDoc.CloseDocument event is called.
Public propertyStatic memberIsCloudZooNode
Returns true if rhino is currently using the Cloud Zoo false otherwise
Public propertyStatic memberIsExiting
Returns true if Rhino is in the process of exiting, false otherwise. This can be true even before the Closing event fires, such as when RhinoDoc.CloseDocument event is called.
Public propertyStatic memberIsInternetAccessAllowed
Returns true when Rhino is allowed to access the Internet, false otherwise. Note, this does not test if Internet access is available.
Public propertyStatic memberIsLicenseValidated
Returns true if the license is validated false otherwise
Public propertyStatic memberIsPreRelease
Returns true if Rhino is compiled a s pre-release build (Beta, WIP) false otherwise
Public propertyStatic memberIsRunningAutomated
Is Rhino currently being executed through automation
Public propertyStatic memberIsRunningHeadless
Is Rhino currently being executed in headless mode
Public propertyStatic memberIsSafeModeEnabled
Is Rhino being executed in safe mode
Public propertyStatic memberIsSkinned
Is Rhino currently using custom, user-interface Skin.
Public propertyStatic memberLicenseExpires
Returns true if the license will expire false otherwise
Public propertyStatic memberLicenseUserName
Gets the name of the user that owns the license or lease.
Public propertyStatic memberLicenseUserOrganization
Gets the name of the organization of the user that owns the license or lease.
Public propertyStatic memberLoggedInUserAvatar
Returns the logged in user's avatar picture. Returns a default avatar if the user does not have an avatar or if the avatar could not be fetched.
Public propertyStatic memberLoggedInUserName
Returns the name of the logged in user, or null if the user is not logged in.
Public propertyStatic memberName
Gets the application name.
Public propertyStatic memberNodeType
Gets license the node type.
Public propertyStatic memberRhino2Id
Gets the ID of Rhino 2.
Public propertyStatic memberRhino3Id
Gets the ID of Rhino 3.
Public propertyStatic memberRhino4Id
Gets the ID of Rhino 4.
Public propertyStatic memberRhino5Id
Gets the ID of Rhino 5
Public propertyStatic memberRhino6Id
Gets the ID of Rhino 6
Public propertyStatic memberRhino7Id
Gets the ID of Rhino 7
Public propertyStatic memberSchemeName
Gets the current Registry scheme name.
Public propertyStatic memberSdkServiceRelease
Rhino SDK 9 digit SDK service release number in the form YYYYMMDDn Service release of the Rhino SDK supported by this executable. Rhino will only load plug-ins that require a service release of <= this release number. For example, SR1 will load all plug-ins made with any SDK released up through and including the SR1 SDK. But, SR1 will not load a plug-in built using the SR2 SDK. If an "old" Rhino tries to load a "new" plug-in, the user is told that they have to get a free Rhino.exe update in order for the plug-in to load. Rhino.exe updates are available from http://www.rhino3d.com.
Public propertyStatic memberSdkVersion
Rhino SDK 9 digit SDK version number in the form YYYYMMDDn Rhino will only load plug-ins that were build with exactly the same version of the SDK.
Public propertyStatic memberSendWriteToConsole
Enable or disable sending command window strings to the console RhinoApp.Write(...) calls would be sent to the console when this is enabled
Public propertyStatic memberSerialNumber
Gets the product serial number, as seen in Rhino's ABOUT dialog box.
Public propertyStatic memberToolbarFiles
Collection of currently open toolbar files in the application
Public propertyStatic memberUpdatesAndStatisticsStatus
Returns true when Rhino is allowed to access the Internet, false otherwise. Note, this does not test if Internet access is available.
Public propertyStatic memberUserIsLoggedIn
Returns true if the user is logged in; else returns false. A logged in user does not guarantee that the auth tokens managed by the CloudZooManager instance are valid.
Public propertyStatic memberValidationGracePeriodDaysLeft
Returns number of days within which validation must occur. Zero when validation grace period has expired. Raises InvalidLicenseTypeException if LicenseType is one of: EvaluationSaveLimited EvaluationTimeLimited Viewer Unknown
Public propertyStatic memberVersion
File version of the main Rhino process
Public propertyStatic memberVersionControlRevision
McNeel version control revision identifier at the time this version of Rhino was built.
Top
Methods
  NameDescription
Public methodStatic memberAskUserForRhinoLicense
Display UI asking the user to enter a license for Rhino or use one from the Zoo.
Public methodStatic memberCapturedCommandWindowStrings
Get list of strings sent to the command window through calls to Write or WriteLine when capturing has been enabled
Public methodStatic memberChangeLicenseKey
Display UI asking the user to enter a license for the product specified by licenseId.
Public methodStatic memberClearCommandHistoryWindow
Clear the text in Rhino's command history window.
Public methodStatic memberExecuteCommand
Execute a Rhino command.
Public methodStatic memberExit
Exits, or closes, Rhino.
Public methodStatic memberExit(Boolean)
Exits, or forcefully closes Rhino. A prompt to allow saving will appear if necessary when forcefully exiting Works on Windows and MacOS true to allow the user to cancel exiting false to force exit
Public methodStatic memberGetDataDirectory(Boolean, Boolean)
Gets the data directory.
Public methodStatic memberGetDataDirectory(Boolean, Boolean, String)
Gets the data directory.
Public methodStatic memberGetExecutableDirectory
directory
Public methodStatic memberGetPlugInObject(Guid)
Gets the object that is returned by PlugIn.GetPlugInObject for a given plug-in. This function attempts to find and load a plug-in with a given Id. When a plug-in is found, it's GetPlugInObject function is called and the result is returned here. Note the plug-in must have already been installed in Rhino or the plug-in manager will not know where to look for a plug-in with a matching id.
Public methodStatic memberGetPlugInObject(String)
Gets the object that is returned by PlugIn.GetPlugInObject for a given plug-in. This function attempts to find and load a plug-in with a given name. When a plug-in is found, it's GetPlugInObject function is called and the result is returned here. Note the plug-in must have already been installed in Rhino or the plug-in manager will not know where to look for a plug-in with a matching name.
Public methodStatic memberInFullScreen
Verifies that Rhino is running in full screen mode.
Public methodStatic memberInvokeAndWait
Work-In-Progress. Testing this with our unit test framework
Public methodStatic memberInvokeOnUiThread
Execute a function on the main UI thread.
Public methodStatic memberIsInstallationBeta
If licenseType is a beta license, returns true. A beta license grants full use of the product during the pre-release development period.
Public methodStatic memberIsInstallationCommercial
If licenseType is a commercial license, returns true. A commercial license grants full use of the product.
Public methodStatic memberIsInstallationEvaluation
If licenseType is an evaluation license, returns true. An evaluation license limits the ability of Rhino to save based on either the number of saves or a fixed period of time.
Public methodStatic memberLoginToCloudZoo
Logs in to the cloud zoo.
Public methodStatic memberMainWindowHandle
Gets the HWND of the Rhino main window.
Public methodStatic memberOutputDebugString
Print a string to the Visual Studio Output window, if a debugger is attached. Note that the developer needs to add a newline manually if the next output should come on a separate line.
Public methodStatic memberParseTextField
Public methodStatic memberPostCancelEvent
Post a cancel event to the command line
Public methodStatic memberPostEnterEvent
Post an enter event to the command line
Public methodStatic memberRefreshRhinoLicense
Refresh the license used by Rhino. This allows any part of Rhino to ensure that the most current version of the license file on disk is in use.
Public methodStatic memberReleaseMouseCapture
Releases the mouse capture.
Public methodStatic memberRunMenuScript
Run a Rhino menu item script. Will add the selected menu string to the MRU command menu.
Public methodStatic memberRunningInRdp
Find out if Rhino is running in a remote session
Public methodStatic memberRunningOnVMWare
Verifies that Rhino is running on VMWare
Public methodStatic memberRunScript(String, Boolean)
Runs a Rhino command script.
Public methodStatic memberRunScript(String, String, Boolean)
Runs a Rhino command script.
Public methodStatic memberRunScript(UInt32, String, Boolean)
Runs a Rhino command script.
Public methodStatic memberRunScript(UInt32, String, String, Boolean)
Runs a Rhino command script.
Public methodStatic memberSendKeystrokes
Sends a string of printable characters, including spaces, to Rhino's command line.
Public methodStatic memberSetCommandPrompt(String)
Set Rhino command prompt.
Public methodStatic memberSetCommandPrompt(String, String)
Sets the command prompt in Rhino.
Public methodStatic memberSetCommandPromptMessage
Set the text that appears in the Rhino command prompt. In general, you should use the SetCommandPrompt functions. In rare cases, like worker thread messages, the message that appears in the prompt has non-standard formatting. In these rare cases, SetCommandPromptMessage can be used to literally specify the text that appears in the command prompt window.
Public methodStatic memberSetFocusToMainWindow
Sets the focus to the main window. This function attempts to use the ActiveDoc on Mac to figure out which window to set focus to.
Public methodStatic memberSetFocusToMainWindow(RhinoDoc)
Sets the focus to the main windows for a given document
Public methodStatic memberWait
Pauses to keep Windows message pump alive so views will update and windows will repaint.
Public methodStatic memberWrite(String)
Print formatted text in the command window.
Public methodStatic memberWrite(String, Object)
Print formatted text in the command window.
Public methodStatic memberWrite(String, Object, Object)
Print formatted text in the command window.
Public methodStatic memberWrite(String, Object, Object, Object)
Print formatted text in the command window.
Public methodStatic memberWriteLine
Print a newline in the command window.
Public methodStatic memberCode exampleWriteLine(String)
Print text in the command window.
Public methodStatic memberCode exampleWriteLine(String, Object)
Print formatted text with a newline in the command window.
Public methodStatic memberWriteLine(String, Object, Object)
Print formatted text with a newline in the command window.
Public methodStatic memberWriteLine(String, Object, Object, Object)
Print formatted text with a newline in the command window.
Top
Events
  NameDescription
Public eventStatic memberAppSettingsChanged
Is raised when settings are changed.
Public eventStatic memberClosing
Is raised when the application is about to close.
Public eventStatic memberEscapeKeyPressed
Can add or removed delegates that are raised when the escape key is clicked.
Public eventStatic memberIdle
Occurs when the application finishes processing and is about to enter the idle state
Public eventStatic memberInitialized
Is raised when the application is fully initialized.
Public eventStatic memberKeyboardEvent
Can add or removed delegates that are raised by a keyboard event.
Public eventStatic memberLicenseStateChanged
Fires when the license state has changed
Public eventStatic memberMainLoop
Gets called every loop iteration inside Rhino's main message loop.
Public eventStatic memberRdkCacheImageChanged
Monitors when the RDK thumbnail cache images are changed.
Public eventStatic memberRdkGlobalSettingsChanged
Monitors when RDK global settings are modified.
Public eventStatic memberRdkNewDocument
Monitors when RDK document information is rebuilt.
Public eventStatic memberRdkPlugInUnloading
Monitors when RDK client plug-ins are unloaded.
Public eventStatic memberRdkUpdateAllPreviews
Monitors when RDK thumbnails are updated.
Public eventStatic memberRendererChanged
Monitors when Rhino's current renderer changes.
Top
See Also