Click or drag to resize

RhinoApp Events

The RhinoApp type exposes the following members.

Events
  NameDescription
Public eventStatic memberAppSettingsChanged
Is raised when settings are changed.
Public eventStatic memberClosing
Is raised when the application is about to close.
Public eventStatic memberEscapeKeyPressed
Can add or removed delegates that are raised when the escape key is clicked.
Public eventStatic memberIdle
Occurs when the application finishes processing and is about to enter the idle state
Public eventStatic memberInitialized
Is raised when the application is fully initialized.
Public eventStatic memberKeyboardEvent
Can add or removed delegates that are raised by a keyboard event.
Public eventStatic memberLicenseStateChanged
Fires when the license state has changed
Public eventStatic memberMainLoop
Gets called every loop iteration inside Rhino's main message loop.
Public eventStatic memberRdkCacheImageChanged
Monitors when the RDK thumbnail cache images are changed.
Public eventStatic memberRdkGlobalSettingsChanged
Monitors when RDK global settings are modified.
Public eventStatic memberRdkNewDocument
Monitors when RDK document information is rebuilt.
Public eventStatic memberRdkPlugInUnloading
Monitors when RDK client plug-ins are unloaded.
Public eventStatic memberRdkUpdateAllPreviews
Monitors when RDK thumbnails are updated.
Public eventStatic memberRendererChanged
Monitors when Rhino's current renderer changes.
Top
See Also