Click or drag to resize

RhinoApp Properties

The RhinoApp type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberBuildDate
Gets the build date.
Public propertyStatic memberCanSave
Returns true when Rhino is allowed to save, false otherwise Conditions where Rhino is not allowed to save are: when evaluation licenses are expired; when a Cloud Zoo lease is expired; when a license is shared by a single user on multiple computers, and the current computer is not active.
Public propertyStatic memberCheckNewObject
Returns true if Rhino will validate each object added to the document. This can be time consuming but is valuable for debugging.
Public propertyStatic memberCommandHistoryWindowText
Text in Rhino's command history window.
Public propertyStatic memberCommandLineOut
Provides a TextWriter that can write to the command line.
Public propertyStatic memberCommandPrompt
Rhino command prompt.
Public propertyStatic memberCommandWindowCaptureEnabled
Enable or disable capturing of the strings sent to the CommandWindow through Write and WriteLine calls
Public propertyStatic memberCurrentRhinoId
Gets the current ID of Rhino.
Public propertyStatic memberDaysUntilExpiration
Returns number of days until license expires. Zero when license is expired. Raises InvalidLicenseTypeException if LicenseExpires would return false.
Public propertyStatic memberDefaultUiFont
Default font used to render user interface
Public propertyStatic memberExeServiceRelease
Service release version of Rhino executable (0, 1, 2, ...) The integer is the service release number of Rhino. For example, this function returns "0" if Rhino V4SR0 is running and returns "1" if Rhino V4SR1 is running.
Public propertyStatic memberExeVersion
Major version of Rhino executable 4, 5, ...
Public propertyStatic memberInCommand
Gets the nested command count.
Public propertyStatic memberInstallationType
Gets the product installation type, as seen in Rhino's ABOUT dialog box.
Public propertyStatic memberInstallationTypeString
Gets the type of installation (product edition) of the license or lease.
Public propertyStatic memberInvokeRequired
Returns true if we are currently not running on the main user interface thread
Public propertyStatic memberIsClosing
Returns true if Rhino is in the process of closing, false otherwise. This can be true even before the Closing event fires, such as when RhinoDoc.CloseDocument event is called.
Public propertyStatic memberIsCloudZooNode
Returns true if rhino is currently using the Cloud Zoo false otherwise
Public propertyStatic memberIsExiting
Returns true if Rhino is in the process of exiting, false otherwise. This can be true even before the Closing event fires, such as when RhinoDoc.CloseDocument event is called.
Public propertyStatic memberIsInternetAccessAllowed
Returns true when Rhino is allowed to access the Internet, false otherwise. Note, this does not test if Internet access is available.
Public propertyStatic memberIsLicenseValidated
Returns true if the license is validated false otherwise
Public propertyStatic memberIsOnMainThread
Is the current thread the main thread
Public propertyStatic memberIsPreRelease
Returns true if Rhino is compiled a s pre-release build (Beta, WIP) false otherwise
Public propertyStatic memberIsRunningAutomated
Is Rhino currently being executed through automation
Public propertyStatic memberIsRunningHeadless
Is Rhino currently being executed in headless mode
Public propertyStatic memberIsSafeModeEnabled
Is Rhino being executed in safe mode
Public propertyStatic memberIsSkinned
Is Rhino currently using custom, user-interface Skin.
Public propertyStatic memberLicenseExpires
Returns true if the license will expire false otherwise
Public propertyStatic memberLicenseUserName
Gets the name of the user that owns the license or lease.
Public propertyStatic memberLicenseUserOrganization
Gets the name of the organization of the user that owns the license or lease.
Public propertyStatic memberLoggedInUserAvatar
Returns the logged in user's avatar picture. Returns a default avatar if the user does not have an avatar or if the avatar could not be fetched.
Public propertyStatic memberLoggedInUserName
Returns the name of the logged in user, or null if the user is not logged in.
Public propertyStatic memberName
Gets the application name.
Public propertyStatic memberNodeType
Gets license the node type.
Public propertyStatic memberRhino2Id
Gets the ID of Rhino 2.
Public propertyStatic memberRhino3Id
Gets the ID of Rhino 3.
Public propertyStatic memberRhino4Id
Gets the ID of Rhino 4.
Public propertyStatic memberRhino5Id
Gets the ID of Rhino 5
Public propertyStatic memberRhino6Id
Gets the ID of Rhino 6
Public propertyStatic memberRhino7Id
Gets the ID of Rhino 7
Public propertyStatic memberSchemeName
Gets the current Registry scheme name.
Public propertyStatic memberSdkServiceRelease
Rhino SDK 9 digit SDK service release number in the form YYYYMMDDn Service release of the Rhino SDK supported by this executable. Rhino will only load plug-ins that require a service release of <= this release number. For example, SR1 will load all plug-ins made with any SDK released up through and including the SR1 SDK. But, SR1 will not load a plug-in built using the SR2 SDK. If an "old" Rhino tries to load a "new" plug-in, the user is told that they have to get a free Rhino.exe update in order for the plug-in to load. Rhino.exe updates are available from http://www.rhino3d.com.
Public propertyStatic memberSdkVersion
Rhino SDK 9 digit SDK version number in the form YYYYMMDDn Rhino will only load plug-ins that were build with exactly the same version of the SDK.
Public propertyStatic memberSendWriteToConsole
Enable or disable sending command window strings to the console RhinoApp.Write(...) calls would be sent to the console when this is enabled
Public propertyStatic memberSerialNumber
Gets the product serial number, as seen in Rhino's ABOUT dialog box.
Public propertyStatic memberToolbarFiles
Collection of currently open toolbar files in the application
Public propertyStatic memberUpdatesAndStatisticsStatus
Returns true when Rhino is allowed to access the Internet, false otherwise. Note, this does not test if Internet access is available.
Public propertyStatic memberUserIsLoggedIn
Returns true if the user is logged in; else returns false. A logged in user does not guarantee that the auth tokens managed by the CloudZooManager instance are valid.
Public propertyStatic memberValidationGracePeriodDaysLeft
Returns number of days within which validation must occur. Zero when validation grace period has expired. Raises InvalidLicenseTypeException if LicenseType is one of: EvaluationSaveLimited EvaluationTimeLimited Viewer Unknown
Public propertyStatic memberVersion
File version of the main Rhino process
Public propertyStatic memberVersionControlRevision
McNeel version control revision identifier at the time this version of Rhino was built.
Top
See Also