Click or drag to resize

RhinoApp Methods

The RhinoApp type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAskUserForRhinoLicense
Display UI asking the user to enter a license for Rhino or use one from the Zoo.
Public methodStatic memberCapturedCommandWindowStrings
Get list of strings sent to the command window through calls to Write or WriteLine when capturing has been enabled
Public methodStatic memberChangeLicenseKey
Display UI asking the user to enter a license for the product specified by licenseId.
Public methodStatic memberClearCommandHistoryWindow
Clear the text in Rhino's command history window.
Public methodStatic memberExecuteCommand
Execute a Rhino command.
Public methodStatic memberExit
Exits, or closes, Rhino.
Public methodStatic memberExit(Boolean)
Exits, or forcefully closes Rhino. A prompt to allow saving will appear if necessary when forcefully exiting Works on Windows and MacOS true to allow the user to cancel exiting false to force exit
Public methodStatic memberGetDataDirectory(Boolean, Boolean)
Gets the data directory.
Public methodStatic memberGetDataDirectory(Boolean, Boolean, String)
Gets the data directory.
Public methodStatic memberGetExecutableDirectory
directory
Public methodStatic memberGetPlugInObject(Guid)
Gets the object that is returned by PlugIn.GetPlugInObject for a given plug-in. This function attempts to find and load a plug-in with a given Id. When a plug-in is found, it's GetPlugInObject function is called and the result is returned here. Note the plug-in must have already been installed in Rhino or the plug-in manager will not know where to look for a plug-in with a matching id.
Public methodStatic memberGetPlugInObject(String)
Gets the object that is returned by PlugIn.GetPlugInObject for a given plug-in. This function attempts to find and load a plug-in with a given name. When a plug-in is found, it's GetPlugInObject function is called and the result is returned here. Note the plug-in must have already been installed in Rhino or the plug-in manager will not know where to look for a plug-in with a matching name.
Public methodStatic memberInFullScreen
Verifies that Rhino is running in full screen mode.
Public methodStatic memberInvokeAndWait
Work-In-Progress. Testing this with our unit test framework
Public methodStatic memberInvokeOnUiThread
Execute a function on the main UI thread.
Public methodStatic memberIsInstallationBeta
If licenseType is a beta license, returns true. A beta license grants full use of the product during the pre-release development period.
Public methodStatic memberIsInstallationCommercial
If licenseType is a commercial license, returns true. A commercial license grants full use of the product.
Public methodStatic memberIsInstallationEvaluation
If licenseType is an evaluation license, returns true. An evaluation license limits the ability of Rhino to save based on either the number of saves or a fixed period of time.
Public methodStatic memberLoginToCloudZoo
Logs in to the cloud zoo.
Public methodStatic memberMainWindowHandle
Gets the HWND of the Rhino main window.
Public methodStatic memberOutputDebugString
Print a string to the Visual Studio Output window, if a debugger is attached. Note that the developer needs to add a newline manually if the next output should come on a separate line.
Public methodStatic memberParseTextField
Public methodStatic memberPostCancelEvent
Post a cancel event to the command line
Public methodStatic memberPostEnterEvent
Post an enter event to the command line
Public methodStatic memberRefreshRhinoLicense
Refresh the license used by Rhino. This allows any part of Rhino to ensure that the most current version of the license file on disk is in use.
Public methodStatic memberReleaseMouseCapture
Releases the mouse capture.
Public methodStatic memberRunMenuScript
Run a Rhino menu item script. Will add the selected menu string to the MRU command menu.
Public methodStatic memberRunningInRdp
Find out if Rhino is running in a remote session
Public methodStatic memberRunningOnVMWare
Verifies that Rhino is running on VMWare
Public methodStatic memberRunScript(String, Boolean)
Runs a Rhino command script.
Public methodStatic memberRunScript(String, String, Boolean)
Runs a Rhino command script.
Public methodStatic memberRunScript(UInt32, String, Boolean)
Runs a Rhino command script.
Public methodStatic memberRunScript(UInt32, String, String, Boolean)
Runs a Rhino command script.
Public methodStatic memberSendKeystrokes
Sends a string of printable characters, including spaces, to Rhino's command line.
Public methodStatic memberSetCommandPrompt(String)
Set Rhino command prompt.
Public methodStatic memberSetCommandPrompt(String, String)
Sets the command prompt in Rhino.
Public methodStatic memberSetCommandPromptMessage
Set the text that appears in the Rhino command prompt. In general, you should use the SetCommandPrompt functions. In rare cases, like worker thread messages, the message that appears in the prompt has non-standard formatting. In these rare cases, SetCommandPromptMessage can be used to literally specify the text that appears in the command prompt window.
Public methodStatic memberSetFocusToMainWindow
Sets the focus to the main window. This function attempts to use the ActiveDoc on Mac to figure out which window to set focus to.
Public methodStatic memberSetFocusToMainWindow(RhinoDoc)
Sets the focus to the main windows for a given document
Public methodStatic memberWait
Pauses to keep Windows message pump alive so views will update and windows will repaint.
Public methodStatic memberWrite(String)
Print formatted text in the command window.
Public methodStatic memberWrite(String, Object)
Print formatted text in the command window.
Public methodStatic memberWrite(String, Object, Object)
Print formatted text in the command window.
Public methodStatic memberWrite(String, Object, Object, Object)
Print formatted text in the command window.
Public methodStatic memberWriteLine
Print a newline in the command window.
Public methodStatic memberCode exampleWriteLine(String)
Print text in the command window.
Public methodStatic memberCode exampleWriteLine(String, Object)
Print formatted text with a newline in the command window.
Public methodStatic memberWriteLine(String, Object, Object)
Print formatted text with a newline in the command window.
Public methodStatic memberWriteLine(String, Object, Object, Object)
Print formatted text with a newline in the command window.
Top
See Also