MeshFaceNormalList Class |
Namespace: Rhino.Geometry.Collections
The MeshFaceNormalList type exposes the following members.
Name | Description | |
---|---|---|
![]() | Capacity |
Gets or sets the total number of face normals the internal data structure can hold without resizing.
|
![]() | Count |
Gets or sets the number of mesh face normals.
|
![]() | Item |
Gets or sets the face normal at the given face index.
The index must be valid or an IndexOutOfRangeException will be thrown.
|
Name | Description | |
---|---|---|
![]() | AddFaceNormal(Vector3d) |
Appends a face normal to the list of mesh face normals.
|
![]() | AddFaceNormal(Vector3f) |
Appends a face normal to the list of mesh face normals.
|
![]() | AddFaceNormal(Double, Double, Double) |
Appends a face normal to the list of mesh face normals.
|
![]() | AddFaceNormal(Single, Single, Single) |
Appends a face normal to the list of mesh face normals.
|
![]() | Clear |
Clears the Face Normal list on the mesh.
|
![]() | ComputeFaceNormals |
Computes all the face normals for this mesh based on the physical shape of the mesh.
|
![]() | Destroy |
Releases all memory allocated to store face normals. The list capacity will be 0 after this call.
Subsequent calls can add new items. |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | GetEnumerator |
Gets an enumerator that yields all normals (vectors) in this collection.
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | SetFaceNormal(Int32, Vector3d) |
Sets a face normal vector at an index using a single-precision vector.
|
![]() | SetFaceNormal(Int32, Vector3f) |
Sets a face normal vector at an index using a single-precision vector.
|
![]() | SetFaceNormal(Int32, Double, Double, Double) |
Sets a face normal vector at an index using three double-precision numbers.
|
![]() | SetFaceNormal(Int32, Single, Single, Single) |
Sets a face normal vector at an index using three single-precision numbers.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![]() | UnitizeFaceNormals |
Unitizes all the existing face normals.
|