Click or drag to resize

MeshFaceNormalList Methods

The MeshFaceNormalList type exposes the following members.

Methods
  NameDescription
Public methodAddFaceNormal(Vector3d)
Appends a face normal to the list of mesh face normals.
Public methodAddFaceNormal(Vector3f)
Appends a face normal to the list of mesh face normals.
Public methodAddFaceNormal(Double, Double, Double)
Appends a face normal to the list of mesh face normals.
Public methodAddFaceNormal(Single, Single, Single)
Appends a face normal to the list of mesh face normals.
Public methodClear
Clears the Face Normal list on the mesh.
Public methodComputeFaceNormals
Computes all the face normals for this mesh based on the physical shape of the mesh.
Public methodDestroy
Releases all memory allocated to store face normals. The list capacity will be 0 after this call.

Subsequent calls can add new items.

Public methodGetEnumerator
Gets an enumerator that yields all normals (vectors) in this collection.
Public methodSetFaceNormal(Int32, Vector3d)
Sets a face normal vector at an index using a single-precision vector.
Public methodSetFaceNormal(Int32, Vector3f)
Sets a face normal vector at an index using a single-precision vector.
Public methodSetFaceNormal(Int32, Double, Double, Double)
Sets a face normal vector at an index using three double-precision numbers.
Public methodSetFaceNormal(Int32, Single, Single, Single)
Sets a face normal vector at an index using three single-precision numbers.
Public methodUnitizeFaceNormals
Unitizes all the existing face normals.
Top
See Also