Click or drag to resize

BrepEdgeList Class

Provides access to all the Edges in a Brep object.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsBrepEdgeList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class BrepEdgeList : IEnumerable<BrepEdge>, 
	IEnumerable

The BrepEdgeList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of brep edges.
Public propertyItem
Gets the BrepEdge at the given index. The index must be valid or an IndexOutOfRangeException will be thrown.
Top
Methods
  NameDescription
Public methodAdd(Int32)
Create and add a new edge to this list
Public methodAdd(BrepVertex, BrepVertex, Int32, Double)
Create and add a new edge to this list
Public methodAdd(Int32, Int32, Int32, Double)
Create and add a new edge to this list
Public methodAdd(BrepVertex, BrepVertex, Int32, Interval, Double)
Create and add a new edge to this list
Public methodAdd(Int32, Int32, Int32, Interval, Double)
Create and add a new edge to this list
Public methodGetEnumerator
Gets an enumerator that visits all edges.
Public methodMergeAllEdges
Merges all possible Brep edges. Edges across kinks cannot be merged. A pair of adjacent edges in a Brep are mergeable if the angle between them is less than tolerance and the valence of the shared vertex is 2.
Public methodMergeEdge
Merge adjacent edges to a specified edge recursively. A pair of adjacent edges in a Brep are mergeable if the angle between them is less than tolerance and the valence of the shared vertex is 2.
Public methodRemoveNakedMicroEdges(Double)
Finds any naked edges with the same start and end vertex and an arc-length less than tolerance and attempts to remove them by removing trims and extending the adjacent to meet.
Public methodRemoveNakedMicroEdges(Double, Boolean)
Finds any naked edges with the same start and end vertex and an arc-length less than tolerance and attempts to remove them by removing trims and extending the adjacent to meet.
Public methodSplitEdgeAtParameters
Splits an edge at the specified parameters.
Public methodSplitKinkyEdge
Splits the edge into G1 pieces.
Top
See Also