Click or drag to resize

BrepEdgeListAdd Method (BrepVertex, BrepVertex, Int32, Double)

Create and add a new edge to this list

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.4
Syntax
public BrepEdge Add(
	BrepVertex startVertex,
	BrepVertex endVertex,
	int curve3dIndex,
	double edgeTolerance
)

Parameters

startVertex
Type: Rhino.GeometryBrepVertex

[Missing <param name="startVertex"/> documentation for "M:Rhino.Geometry.Collections.BrepEdgeList.Add(Rhino.Geometry.BrepVertex,Rhino.Geometry.BrepVertex,System.Int32,System.Double)"]

endVertex
Type: Rhino.GeometryBrepVertex

[Missing <param name="endVertex"/> documentation for "M:Rhino.Geometry.Collections.BrepEdgeList.Add(Rhino.Geometry.BrepVertex,Rhino.Geometry.BrepVertex,System.Int32,System.Double)"]

curve3dIndex
Type: SystemInt32

[Missing <param name="curve3dIndex"/> documentation for "M:Rhino.Geometry.Collections.BrepEdgeList.Add(Rhino.Geometry.BrepVertex,Rhino.Geometry.BrepVertex,System.Int32,System.Double)"]

edgeTolerance
Type: SystemDouble

[Missing <param name="edgeTolerance"/> documentation for "M:Rhino.Geometry.Collections.BrepEdgeList.Add(Rhino.Geometry.BrepVertex,Rhino.Geometry.BrepVertex,System.Int32,System.Double)"]

Return Value

Type: BrepEdge

[Missing <returns> documentation for "M:Rhino.Geometry.Collections.BrepEdgeList.Add(Rhino.Geometry.BrepVertex,Rhino.Geometry.BrepVertex,System.Int32,System.Double)"]

See Also