Click or drag to resize

BrepEdgeListSplitEdgeAtParameters Method

Splits an edge at the specified parameters.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int SplitEdgeAtParameters(
	int edgeIndex,
	IEnumerable<double> edgeParameters
)

Parameters

edgeIndex
Type: SystemInt32
The index of the edge to be addressed.
edgeParameters
Type: System.Collections.GenericIEnumerableDouble
The parameter along that edge.

Return Value

Type: Int32
Number of splits applied to the edge.
Remarks
This function leaves deleted stuff in the brep. Call Brep.Compact() to remove deleted stuff.
See Also