Click or drag to resize

DimStyleTable Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Tables.DimStyleTable"]

Inheritance Hierarchy
SystemObject
  Rhino.FileIOCommonComponentTableDimensionStyle
    Rhino.DocObjects.TablesRhinoDocCommonTableDimensionStyle
      Rhino.DocObjects.TablesDimStyleTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class DimStyleTable : RhinoDocCommonTable<DimensionStyle>, 
	ICollection<DimensionStyle>, IEnumerable<DimensionStyle>, IEnumerable

The DimStyleTable type exposes the following members.

Properties
Methods
  NameDescription
Public methodAdd(String)
Adds a new AnnotationStyle to the document. The new AnnotationStyle will be initialized with the current default AnnotationStyle properties.
Public methodAdd(DimensionStyle, Boolean)
Adds a new DimensionStyle to the document.
Public methodAdd(String, Boolean)
Adds a new AnnotationStyle to the document. The new AnnotationStyle will be initialized with the current default AnnotationStyle properties.
Public methodDelete(DimensionStyle)
Removes an annotation style.
(Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Int32, Boolean)
Public methodFind(Guid, Boolean)
Public methodFind(String, Boolean) Obsolete.
Public methodFindIndex
Retrieves a DimensionStyle object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodFindName
Finds the DimensionStyle with a given name and returns it. None is returned if no DimensionStyle is found.
Public methodFindRoot
Public methodGetEnumerator (Overrides CommonComponentTableTGetEnumerator.)
Public methodGetUnusedStyleName
Get a unique name for a style that does not already exist in the DimStyle table
Public methodGetUnusedStyleName(String)
Get a unique name for a dimension style that does not already exist in the DimStyle table
Public methodModify(DimensionStyle, AnnotationBase)
Public methodModify(DimensionStyle, Guid, Boolean)
Modifies dimension style settings.
Public methodModify(DimensionStyle, Int32, Boolean)
Modifies dimension style settings.
Public methodSetCurrent
Sets the Current property.
Public methodSetCurrentDimensionStyleIndex Obsolete.
Do not use. Use the SetCurrent(Int32, Boolean) method.
Top
See Also