DimStyleTable Methods |
The DimStyleTable type exposes the following members.
Name | Description | |
---|---|---|
Add(String) |
Adds a new AnnotationStyle to the document. The new AnnotationStyle will be initialized
with the current default AnnotationStyle properties.
| |
Add(DimensionStyle, Boolean) |
Adds a new DimensionStyle to the document.
| |
Add(String, Boolean) |
Adds a new AnnotationStyle to the document. The new AnnotationStyle will be initialized
with the current default AnnotationStyle properties.
Delete(DimensionStyle) |
Removes an annotation style.
(Overrides CommonComponentTableTDelete(T).) | |
Delete(Int32, Boolean) | ||
Find(Guid, Boolean) | ||
Find(String, Boolean) | Obsolete. | |
FindId |
Uses the guid to find a model component. Deleted objects cannot be found by id.
The guid is the value that is stored in the .Id property.
In a single document, no two active objects have the same guid. If an object is
replaced with a new object, then the guid persists. For example, if the _Move command
moves an object, then the moved object inherits its guid from the starting object.
If the Copy command copies an object, then the copy gets a new guid. This guid persists
FindIndex |
Retrieves a DimensionStyle object based on Index. This search type of search is discouraged.
We are moving towards using only IDs for all tables.
| |
FindName |
Finds the DimensionStyle with a given name and returns it. None is returned if no DimensionStyle is found.
| |
FindRoot | ||
GetEnumerator | (Overrides CommonComponentTableTGetEnumerator.) | |
GetUnusedStyleName |
Get a unique name for a style that does not already exist in the DimStyle table
| |
GetUnusedStyleName(String) |
Get a unique name for a dimension style that does not already exist in the DimStyle table
| |
Modify(DimensionStyle, AnnotationBase) | ||
Modify(DimensionStyle, Guid, Boolean) | Modifies dimension style settings. | |
Modify(DimensionStyle, Int32, Boolean) | Modifies dimension style settings. | |
SetCurrent |
Sets the Current property.
| |
SetCurrentDimensionStyleIndex | Obsolete.
Do not use. Use the SetCurrent(Int32, Boolean) method.
| |