Click or drag to resize

UserDictionary Class

Defines the storage data class for a user dictionary.
Inheritance Hierarchy

Namespace:  Rhino.DocObjects.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class UserDictionary : UserData

The UserDictionary type exposes the following members.

Constructors
  NameDescription
Public methodUserDictionary
Initializes a new instance of the UserDictionary class
Top
Properties
  NameDescription
Public propertyDescription
Gets the text "RhinoCommon UserDictionary".
(Overrides UserDataDescription.)
Public propertyDictionary
Gets the dictionary that is associated with this class.

This dictionary is unique.

Public propertyShouldWrite
Writes this entity if the count is larger than 0.
(Overrides UserDataShouldWrite.)
Top
Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Protected methodOnDuplicate
Clones the user data.
(Overrides UserDataOnDuplicate(UserData).)
Protected methodRead
Is called to read this entity.
(Overrides UserDataRead(BinaryArchiveReader).)
Protected methodWrite
Is called to write this entity.
(Overrides UserDataWrite(BinaryArchiveWriter).)
Top
See Also