Click or drag to resize

UserDictionary Methods

The UserDictionary type exposes the following members.

Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Protected methodOnDuplicate
Clones the user data.
(Overrides UserDataOnDuplicate(UserData).)
Protected methodRead
Is called to read this entity.
(Overrides UserDataRead(BinaryArchiveReader).)
Protected methodWrite
Is called to write this entity.
(Overrides UserDataWrite(BinaryArchiveWriter).)
Top
See Also