Click or drag to resize

RhinoView Class

A RhinoView represents a single "window" display of a document. A view could contain one or many RhinoViewports (many in the case of Layout views with detail viewports). Standard Rhino modeling views have one viewport.
Inheritance Hierarchy

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RhinoView

The RhinoView type exposes the following members.

Properties
  NameDescription
Public propertyCode exampleActiveViewport
The ActiveViewport is the same as the MainViewport for standard RhinoViews. In a RhinoPageView, the active viewport may be the RhinoViewport of a child detail object. Most of the time, you will use ActiveViewport unless you explicitly need to work with the main viewport.
Public propertyActiveViewportID
Returns viewport ID for the active viewport. Faster than ActiveViewport function when working with page views.
Public propertyBounds
Gets the size and location of the view including its non-client elements, in pixels, relative to the parent control.
Public propertyClientRectangle
Gets the rectangle that represents the client area of the view.
Public propertyDisplayPipeline
Gets the display pipeline used for this view.
Public propertyDocument
Public propertyStatic memberEnableDrawing
Gets or sets the 'drawing enabled' flag. By default, drawing is enabled.

There are some rare situations where scripts want to disable drawing for a while.

Public propertyFloating
Floating state of RhinoView. if true, then the view will be in a floating frame window. Otherwise the view will be embedded in the main frame.
Public propertyHandle
Gets the window handle that this view is bound to.
Public propertyInDynamicViewChange
true if the view is being dynamically changed by mouse moves, arrow keys, trackballs, etc.
Public propertyMainViewport
A RhinoView contains a "main viewport" that fills the entire view client window. RhinoPageViews may also contain nested child RhinoViewports for implementing detail viewports. The MainViewport will always return this RhinoView's m_vp.
Public propertyMaximized
Public propertyRealtimeDisplayMode
Gets the RealtimeDisplayMode active for this view. null if the view doesn't have a RealtimeDisplayMode set.
Public propertyRuntimeSerialNumber
Public propertyScreenRectangle
Gets the rectangle that represents the client area of the view in screen coordinates.
Public propertySize
Gets or sets the size of the view
Public propertyTitleVisible
Visibility of the viewport title window.
Top
Methods
  NameDescription
Public methodCaptureToBitmap
Capture View contents to a bitmap.
Public methodCaptureToBitmap(DisplayModeDescription)
Capture View contents to a bitmap using a display mode description to define how drawing is performed.
Public methodCaptureToBitmap(DisplayPipelineAttributes)
Captures view contents to a bitmap using display attributes to define how drawing is performed.
Public methodCaptureToBitmap(Size)
Capture View contents to a bitmap.
Public methodCaptureToBitmap(Size, DisplayModeDescription)
Capture View contents to a bitmap using a display mode description to define how drawing is performed.
Public methodCaptureToBitmap(Size, DisplayPipelineAttributes)
Capture View contents to a bitmap using display attributes to define how drawing is performed.
Public methodCode exampleCaptureToBitmap(Boolean, Boolean, Boolean)
Captures the view contents to a bitmap allowing for visibility of grid and axes.
Public methodCaptureToBitmap(Size, Boolean, Boolean, Boolean)
Captures a part of the view contents to a bitmap allowing for visibility of grid and axes.
Public methodClientToScreen(Point)
Public methodClientToScreen(Point2d)
Public methodClose
Remove this View from Rhino. DO NOT attempt to use this instance of this class after calling Close.
Public methodCreateShadedPreviewImage
Creates a bitmap preview image of model.
Public methodCreateWireframePreviewImage
Creates a bitmap preview image of model.
Public methodEquals (Overrides ObjectEquals(Object).)
Public methodStatic memberFromRuntimeSerialNumber
Get a RhinoView from it's unique runtime serial number
Public methodGetHashCode (Overrides ObjectGetHashCode.)
Public methodMouseCaptured
Returns whether or not the mouse is captured in this view.
Public methodCode exampleRedraw
Redraws this view.
Public methodScreenToClient(Point)
Converts a point in screen coordinates to client coordinates for this view.
Public methodScreenToClient(Point2d)
Public methodShowToast(String)
Shows a temporary popup message in the lower right corner of the view
Public methodShowToast(String, Int32)
Shows a temporary popup message in the lower right corner of the view
Public methodShowToast(String, Int32, PointF)
Shows a temporary popup message in the lower right corner of the view
Public methodSpeedTest
Top
Events
See Also