Click or drag to resize

RhinoView Methods

The RhinoView type exposes the following members.

Methods
  NameDescription
Public methodCaptureToBitmap
Capture View contents to a bitmap.
Public methodCaptureToBitmap(DisplayModeDescription)
Capture View contents to a bitmap using a display mode description to define how drawing is performed.
Public methodCaptureToBitmap(DisplayPipelineAttributes)
Captures view contents to a bitmap using display attributes to define how drawing is performed.
Public methodCaptureToBitmap(Size)
Capture View contents to a bitmap.
Public methodCaptureToBitmap(Size, DisplayModeDescription)
Capture View contents to a bitmap using a display mode description to define how drawing is performed.
Public methodCaptureToBitmap(Size, DisplayPipelineAttributes)
Capture View contents to a bitmap using display attributes to define how drawing is performed.
Public methodCode exampleCaptureToBitmap(Boolean, Boolean, Boolean)
Captures the view contents to a bitmap allowing for visibility of grid and axes.
Public methodCaptureToBitmap(Size, Boolean, Boolean, Boolean)
Captures a part of the view contents to a bitmap allowing for visibility of grid and axes.
Public methodClientToScreen(Point)
Public methodClientToScreen(Point2d)
Public methodClose
Remove this View from Rhino. DO NOT attempt to use this instance of this class after calling Close.
Public methodCreateShadedPreviewImage
Creates a bitmap preview image of model.
Public methodCreateWireframePreviewImage
Creates a bitmap preview image of model.
Public methodEquals (Overrides ObjectEquals(Object).)
Public methodStatic memberFromRuntimeSerialNumber
Get a RhinoView from it's unique runtime serial number
Public methodGetHashCode (Overrides ObjectGetHashCode.)
Public methodMouseCaptured
Returns whether or not the mouse is captured in this view.
Public methodCode exampleRedraw
Redraws this view.
Public methodScreenToClient(Point)
Converts a point in screen coordinates to client coordinates for this view.
Public methodScreenToClient(Point2d)
Public methodShowToast(String)
Shows a temporary popup message in the lower right corner of the view
Public methodShowToast(String, Int32)
Shows a temporary popup message in the lower right corner of the view
Public methodShowToast(String, Int32, PointF)
Shows a temporary popup message in the lower right corner of the view
Public methodSpeedTest
Top
See Also