Click or drag to resize

ColorLAB Structure

Represents a LAB (Lightness, A, B) color with double precision floating point channels. LAB colors are based on nonlinearly compressed CIE XYZ color space coordinates. The A and B parameters of a LAB color represent the opponents.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ColorLAB

The ColorLAB type exposes the following members.

Constructors
  NameDescription
Public methodColorLAB(Color)
Constructs a new instance of ColorLAB that is equivalent to an ARGB color.
Public methodColorLAB(Double, Double, Double)
Constructs a new instance of ColorLAB with custom channel values.
Public methodColorLAB(Double, Double, Double, Double)
Constructs a new instance of ColorLAB with custom channel values.
Top
Properties
  NameDescription
Public propertyA
Gets or sets the Base channel. The channel is limited to -1~+1.
Public propertyAlpha
Gets or sets the Alpha channel. The channel is limited to 0~1.
Public propertyB
Gets or sets the Opponent channel. The channel is limited to -1~+1.
Public propertyL
Gets or sets the lightness channel. The channel is limited to 0~1.
Top
Methods
  NameDescription
Public methodStatic memberCreateFromCMYK
Create the nearest LAB equivalent of a CMYK color.
Public methodStatic memberCreateFromHSL
Create the nearest LAB equivalent of an HSL color.
Public methodStatic memberCreateFromHSV
Constructs the nearest LAB equivalent of an HSV color.
Public methodStatic memberCreateFromLCH
Create the nearest LAB equivalent of an LCH color.
Public methodStatic memberCreateFromRGBA
Create the nearest LAB equivalent of an RGBA color.
Public methodStatic memberCreateFromXYZ
Create the nearest LAB equivalent of an XYZ color.
Top
Operators
See Also