Click or drag to resize

Point2f Operators and Type Conversions

The Point2f type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition
Sums two Point2fs.
Public operatorStatic memberDivision
Divides a Point2f by a scalar.
Public operatorStatic memberEquality
Determines whether two Point2f have equal values.
Public operatorStatic member(Point2d to Point2f)
Converts a double-precision point in a single-precision point. Needs explicit casting to help retain precision.
Public operatorStatic memberGreaterThan
Determines whether the first specified Point2f comes after (has superior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified Point2f comes after (has superior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberInequality
Determines whether two Point2f have different values.
Public operatorStatic memberLessThan
Determines whether the first specified Point2f comes before (has inferior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified Point2f comes before (has inferior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberMultiply
Multiplies a Point2f by a scalar.
Public operatorStatic memberSubtraction
Subtracts two Point2fs.
Top
See Also