Click or drag to resize

Interval Operators

The Interval type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition(Double, Interval)
Shifts an interval by a specific amount (addition).
Public operatorStatic memberAddition(Interval, Double)
Shifts a Interval by a specific amount (addition).
Public operatorStatic memberEquality
Determines whether the two Intervals have equal values.
Public operatorStatic memberGreaterThan
Determines whether the first specified Interval comes after (has superior sorting value than) the second Interval.

The lower bound has first evaluation priority.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified Interval comes after (has superior sorting value than) the second Interval, or is equal to it.

The lower bound has first evaluation priority.

Public operatorStatic memberInequality
Determines whether the two Intervals have different values.
Public operatorStatic memberLessThan
Determines whether the first specified Interval comes before (has inferior sorting value than) the second Interval.

The lower bound has first evaluation priority.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified Interval comes before (has inferior sorting value than) the second Interval, or is equal to it.

The lower bound has first evaluation priority.

Public operatorStatic memberSubtraction(Double, Interval)
Shifts an interval by a specific amount (subtraction).
Public operatorStatic memberSubtraction(Interval, Double)
Shifts an interval by a specific amount (subtraction).
Top
See Also