Click or drag to resize

IntervalLessThanOrEqual Operator

Determines whether the first specified Interval comes before (has inferior sorting value than) the second Interval, or is equal to it.

The lower bound has first evaluation priority.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static bool operator <=(
	Interval a,
	Interval b
)

Parameters

a
Type: Rhino.GeometryInterval
First interval.
b
Type: Rhino.GeometryInterval
Second interval.

Return Value

Type: Boolean
true if a[0] is smaller than b[0], or a[0] == b[0] and a[1] is smaller than or equal to b[1]; otherwise, false.
See Also