GetString Methods |
The GetString type exposes the following members.
Name | Description | |
---|---|---|
AcceptColor |
If you want to allow the user to be able to type in a color r,g,b or name
during GetPoint.Get(), GetObject::GetObjects(), etc., then call AcceptColor(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a color,
then the result code GetResult.Color is returned and you can use RhinoGet.Color()
to get the value of the color. If the get accepts points, then the user will not
AcceptEnterWhenDone |
There are instances of RhinoGet that prompt with "Press Enter when Done." yet do not call AcceptNothing().
On the Mac, these instances need an additional call to AcceptEnterWhenDone() so the GetPointOptions dialog
AcceptNothing |
If you want to allow the user to be able to press enter in order to
skip selecting a something in GetPoint.Get(), GetObject::GetObjects(),
AcceptNumber |
If you want to allow the user to be able to type in a number during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptNumber() beforehand.
If the user chooses to type in a number, then the result code GetResult.Number is
returned and you can use RhinoGet.Number() to get the value of the number. If you
are using GetPoint and you want "0" to return (0,0,0) instead of the number zero,
AcceptPoint |
If you want to allow the user to be able to type in a point then call AcceptPoint(true)
before calling GetPoint()/GetObject(). If the user chooses to type in a number, then
the result code GetResult.Point is returned and you can use RhinoGet.Point()
AcceptString |
If you want to allow the user to be able to type in a string during GetPoint.Get(),
GetObject::GetObjects(), etc., then call AcceptString(true) before calling
GetPoint()/GetObject(). If the user chooses to type in a string, then the result code
AcceptUndo |
If you want to allow the user to have an 'undo' option in GetPoint.Get(),
Get | Returns the string that the user typed. By default, space stops the string input. | |
GotDefault |
Returns true if user pressed Enter to accept a default point, number,
Line2d |
Returns two points defining the location in the view window of the 2d line selected
PickRectangle |
If the get was a GetObjects() and the mouse was used to select the objects,
then the returned rectangle has left < right and top < bottom. This rectangle
is the Windows GDI screen coordinates of the picking rectangle.
Point2d |
Returns location in view of point in selected in GetPoint::Get() or GetPoint::Get2dPoint().
Rectangle2d |
Returns the location in the view of the 2d rectangle selected in GetPoint::Get2dRectangle().
rect.left < rect.right and rect.top < rect.bottom
SetCommandPromptDefault |
Sets message that describes what default value will be used if the user presses enter.
This description appears in angle brackets <> in the command prompt window. You do
SetDefaultString |
Sets a string as default value that will be returned
SetWaitDuration |
Sets the wait duration (in milliseconds) of the getter. If the duration passes without