Click or drag to resize

Matrix Methods

The Matrix type exposes the following members.

Methods
  NameDescription
Public methodBackSolve
Solves M*x=b where M is upper triangular with a unit diagonal and b is a column of values.
Public methodBackSolvePoints
Solves M*x=b where M is upper triangular with a unit diagonal and b is a column of 3d points.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodDuplicate
Create a duplicate of this matrix.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGetHashCode
Gets the hash code for this matrix. The hash code will change when the matrix changes so you cannot change matrices while they are stored in hash tables.
(Overrides ObjectGetHashCode.)
Public methodInvert
Modifies this matrix to become its own inverse.

Matrix might be non-invertible (singular) and the return value will be false.

Public methodRowReduce(Double, Point3d, Double)
Row reduces a matrix as the first step in solving M*X=b where b is a column of 3d points.
Public methodRowReduce(Double, Double, Double)
Row reduces a matrix to calculate rank and determinant.
Public methodRowReduce(Double, Double, Double)
Row reduces a matrix as the first step in solving M*X=b where b is a column of values.
Public methodScale
Modifies the current matrix by multiplying its values by a number.
Public methodSetDiagonal
Sets diagonal value and zeros off all non-diagonal values.
Public methodSwapColumns
Exchanges two columns.
Public methodSwapRows
Exchanges two rows.
Public methodTranspose
Modifies this matrix to be its transpose.

This is like swapping rows with columns.

http://en.wikipedia.org/wiki/Transpose

Public methodZero
Sets all values inside the matrix to zero.
Top
See Also