Click or drag to resize

MatrixRowReduce Method (Double, Double, Double)

Row reduces a matrix as the first step in solving M*X=b where b is a column of values.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int RowReduce(
	double zeroTolerance,
	double[] b,
	out double pivot
)

Parameters

zeroTolerance
Type: SystemDouble
(>=0.0) zero tolerance for pivot test. If the absolute value of a pivot is <= zero_tolerance, then the pivot is assumed to be zero.
b
Type: SystemDouble
an array of RowCount values that is row reduced with the matrix.
pivot
Type: SystemDouble
the value of the smallest pivot is returned here.

Return Value

Type: Int32
Rank of the matrix.
Remarks
The matrix itself is row reduced so that the result is an upper triangular matrix with 1's on the diagonal.
See Also