Click or drag to resize

TextEntityCreateCurvesGrouped Method

Creates planar curve from text outline curves. Curves are grouped such that each element in the list being returned represents a single character.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public List<Curve[]> CreateCurvesGrouped(
	DimensionStyle dimstyle,
	bool allowOpen,
	double smallCapsScale,
	double spacing
)

Parameters

dimstyle
Type: Rhino.DocObjectsDimensionStyle

[Missing <param name="dimstyle"/> documentation for "M:Rhino.Geometry.TextEntity.CreateCurvesGrouped(Rhino.DocObjects.DimensionStyle,System.Boolean,System.Double,System.Double)"]

allowOpen
Type: SystemBoolean
Set to true to prevent forced closing of open curves retrieved from glyphs.
smallCapsScale
Type: SystemDouble

[Missing <param name="smallCapsScale"/> documentation for "M:Rhino.Geometry.TextEntity.CreateCurvesGrouped(Rhino.DocObjects.DimensionStyle,System.Boolean,System.Double,System.Double)"]

spacing
Type: SystemDouble

[Missing <param name="spacing"/> documentation for "M:Rhino.Geometry.TextEntity.CreateCurvesGrouped(Rhino.DocObjects.DimensionStyle,System.Boolean,System.Double,System.Double)"]

Return Value

Type: ListCurve

[Missing <returns> documentation for "M:Rhino.Geometry.TextEntity.CreateCurvesGrouped(Rhino.DocObjects.DimensionStyle,System.Boolean,System.Double,System.Double)"]

See Also