Click or drag to resize

PolyCurveSegmentIndex Method

Finds the segment used for evaluation at polycurve_parameter.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int SegmentIndex(
	double polycurveParameter
)

Parameters

polycurveParameter
Type: SystemDouble
Parameter on polycurve for segment lookup.

Return Value

Type: Int32
Index of the segment used for evaluation at polycurve_parameter. If polycurve_parameter < Domain.Min(), then 0 is returned. If polycurve_parameter > Domain.Max(), then Count()-1 is returned.
See Also