Click or drag to resize

PolyCurveSegmentDomain Method

Returns the polycurve sub-domain assigned to a segment curve.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Interval SegmentDomain(
	int segmentIndex
)

Parameters

segmentIndex
Type: SystemInt32
Index of segment.

Return Value

Type: Interval
The polycurve sub-domain assigned to a segment curve. Returns Interval.Unset if segment_index < 0 or segment_index >= Count().
See Also