Click or drag to resize

PolyCurvePolyCurveParameter Method

Converts a segment curve parameter to a polycurve parameter.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public double PolyCurveParameter(
	int segmentIndex,
	double segmentCurveParameter
)

Parameters

segmentIndex
Type: SystemInt32
Index of segment.
segmentCurveParameter
Type: SystemDouble
Parameter on segment.

Return Value

Type: Double
Polycurve evaluation parameter or UnsetValue if the polycurve curve parameter could not be computed.
See Also