GH_LooseChunk Class |
Namespace: GH_IO.Serialization
The GH_LooseChunk type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_LooseChunk(String) |
Create a new loose chunk. A loose chunk does not have an owner archive
and thus cannot store runtime messages.
|
![]() | GH_LooseChunk(String, Int32) |
Create a new loose chunk. A loose chunk does not have an owner archive
and thus cannot store runtime messages.
|
Name | Description | |
---|---|---|
![]() | Archive |
Gets a pointer to the archive that owns the Root of the tree this chunk belongs to.
(Inherited from GH_Chunk.) |
![]() | ArchiveLocation |
Gets a string representing the URI with which the archive is associated.
The location may be a null string.
(Inherited from GH_Chunk.) |
![]() | ChunkCount |
Gets the number of child chunks contained in this chunk.
The set of all child chunks is referred to as a 'litter'.
(Inherited from GH_Chunk.) |
![]() | Chunks |
Gets a pointer to the internal list of child chunks.
Do not access this list unless you know what you are doing.
(Inherited from GH_Chunk.) |
![]() | HasComments |
Gets a value that indicates whether or not comments have been stored in this chunk.
(Inherited from GH_Chunk.) |
![]() | HasIndex |
Gets the index existence implication. The item is considered to have an index qualifier
if the index value is larger than or equal to zero.
(Inherited from GH_Chunk.) |
![]() | HasName |
Gets the name validity of this item.
The item is considered to have an invalid name if string.IsNullOrEmpty(name)
(Inherited from GH_Chunk.) |
![]() | Index |
Gets the index of this chunk. The index is set by the owner of this chunk.
Indices smaller than zero imply no index has been set.
The combination of name+index is always unique among a set of chunks in the same litter.
(Inherited from GH_Chunk.) |
![]() | ItemCount |
Gets the number of items contained in this chunk.
(Inherited from GH_Chunk.) |
![]() | Items |
Gets a pointer to the internal list of items.
Do not access this list unless you know what you are doing.
(Inherited from GH_Chunk.) |
![]() | Name |
Gets the name of this chunk. The name is set by the owner of this chunk.
Names must be at least 1 character long.
The combination of name+index is always unique among a set of chunks in a single litter.
(Inherited from GH_Chunk.) |
Name | Description | |
---|---|---|
![]() | AddComment |
Adds a text comment to this chunk. Comments are serialized only if the output flavour is a
human readable format. Comments are never deserialized, they are purely for the benefit of the
humans reading the file data.
(Inherited from GH_Chunk.) |
![]() | AddMessage |
Log a new message with the top-level archive.
Messages are collected during read/write operations,
and can be displayed to the user upon completion using GH_Archive.ShowMessageLog().
(Inherited from GH_Chunk.) |
![]() | ChunkExists(String) |
Checks whether a chunk with the specified name exists in the litter.
Only chunks without index qualifiers are considered.
Name comparisons are not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | ChunkExists(String, Int32) |
Checks whether a chunk with the specified name and index exists in the litter.
Only chunks with index qualifiers are considered.
Name comparisons are not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | CopyValuesFromChunk |
Copy all values and sub-chunks from another chunk.
(Inherited from GH_Chunk.) |
![]() | CopyValuesToChunk |
Copy all values and sub-chunks in this chunk to another chunk
which does not point to the same archive.
(Inherited from GH_Chunk.) |
![]() | CreateChunk(String) |
Create a new child chunk with the specified name and without an index qualifier.
If another chunk already exists with similar properties, an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | CreateChunk(String, Int32) |
Create a new child chunk with the specified name and index qualifier.
If another chunk already exists with similar properties, an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | Deserialize_Binary |
Deserializes a byte array.
|
![]() | Deserialize_Xml |
Deserializes an Xml string.
|
![]() | FindChunk(String) |
Finds the first chunk in the litter that matches the given name.
Only chunks without index qualifiers are considered.
(Inherited from GH_Chunk.) |
![]() | FindChunk(String, Int32) |
Finds the first chunk in the list that matches the given name and index.
Only chunks with index qualifiers are considered.
(Inherited from GH_Chunk.) |
![]() | FindItem(String) |
Finds the first item that matches the given name.
Only items without index qualifiers are considered.
Name comparisons are not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | FindItem(String, Int32) |
Finds the first item that matches the given name and index.
Only items with index qualifiers are considered.
Name comparisons are not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetBoolean(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetBoolean(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetBoundingBox(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetBoundingBox(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetByte(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetByte(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetByteArray(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetByteArray(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDate(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDate(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDecimal(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDecimal(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDouble(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDouble(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDoubleArray(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDoubleArray(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingBitmap(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingBitmap(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingColor(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingColor(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingPoint(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingPoint(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingPointF(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingPointF(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingRectangle(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingRectangle(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingRectangleF(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingRectangleF(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingSize(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingSize(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingSizeF(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetDrawingSizeF(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetGuid(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetGuid(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInt32(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInt32(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInt64(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInt64(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInterval1D(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInterval1D(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInterval2D(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetInterval2D(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetLine(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetLine(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPath(String, String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPath(String, Int32, String) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPlane(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPlane(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPoint2D(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPoint2D(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPoint3D(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPoint3D(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPoint4D(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetPoint4D(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetSingle(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetSingle(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetString(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetString(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetVersion(String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | GetVersion(String, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | ItemExists(String) |
Gets the occupancy for a specific item name. Only items without index qualifiers are considered.
(Inherited from GH_Chunk.) |
![]() | ItemExists(String, Int32) |
Checks whether an item with the specified name and index exists.
Only items with index qualifiers are considered.
Name comparisons are not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | Read(BinaryReader) |
Read this chunk and all child chunks from a binary stream.
(Inherited from GH_Chunk.) |
![]() | Read(XmlNode) |
Read this chunk and all child chunks from an Xml node.
(Inherited from GH_Chunk.) |
![]() | RemoveChunk(GH_IChunk) |
Remove the specified chunk from the litter.
(Inherited from GH_Chunk.) |
![]() | RemoveChunk(String) |
Remove the first chunk with a matching name.
Only chunks without index qualifiers are considered.
Name comparisons are not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | RemoveChunk(String, Int32) |
Remove the first chunk with a matching name and index.
Only chunks with index qualifiers are considered.
Name comparisons are not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | RemoveItem(String) |
Remove an unindexed item from this chunk.
(Inherited from GH_Chunk.) |
![]() | RemoveItem(String, Int32) |
Remove an indexed item from this chunk.
(Inherited from GH_Chunk.) |
![]() ![]() | Serialize_Binary |
Serializes the data tree into a byte array.
|
![]() ![]() | Serialize_Xml |
Serializes the data tree into an Xml string.
|
![]() | SetBoolean(String, Boolean) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetBoolean(String, Int32, Boolean) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetBoundingBox(String, GH_BoundingBox) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetBoundingBox(String, Int32, GH_BoundingBox) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetByte(String, Byte) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetByte(String, Int32, Byte) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetByteArray(String, Byte) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetByteArray(String, Int32, Byte) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDate(String, DateTime) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDate(String, Int32, DateTime) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDecimal(String, Decimal) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDecimal(String, Int32, Decimal) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDouble(String, Double) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDouble(String, Int32, Double) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDoubleArray(String, Double) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDoubleArray(String, Int32, Double) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingBitmap(String, Bitmap) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingBitmap(String, Int32, Bitmap) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingColor(String, Color) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingColor(String, Int32, Color) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingPoint(String, Point) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingPoint(String, Int32, Point) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingPointF(String, PointF) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingPointF(String, Int32, PointF) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingRectangle(String, Rectangle) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingRectangle(String, Int32, Rectangle) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingRectangleF(String, RectangleF) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingRectangleF(String, Int32, RectangleF) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingSize(String, Size) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingSize(String, Int32, Size) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingSizeF(String, SizeF) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetDrawingSizeF(String, Int32, SizeF) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetGuid(String, Guid) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetGuid(String, Int32, Guid) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInt32(String, Int32) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInt32(String, Int32, Int32) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInt64(String, Int64) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInt64(String, Int32, Int64) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInterval1D(String, GH_Interval1D) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInterval1D(String, Int32, GH_Interval1D) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInterval2D(String, GH_Interval2D) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetInterval2D(String, Int32, GH_Interval2D) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetLine(String, GH_Line) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetLine(String, Int32, GH_Line) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPath(String, String, String) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPath(String, Int32, String, String) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPlane(String, GH_Plane) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPlane(String, Int32, GH_Plane) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPoint2D(String, GH_Point2D) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPoint2D(String, Int32, GH_Point2D) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPoint3D(String, GH_Point3D) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPoint3D(String, Int32, GH_Point3D) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPoint4D(String, GH_Point4D) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetPoint4D(String, Int32, GH_Point4D) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetSingle(String, Single) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetSingle(String, Int32, Single) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetString(String, String) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetString(String, Int32, String) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetVersion(String, GH_Version) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetVersion(String, Int32, GH_Version) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetVersion(String, Int32, Int32, Int32) |
Add a new data item to this chunk.
The name must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | SetVersion(String, Int32, Int32, Int32, Int32) |
Add a new data item to this chunk.
The combination of name and index must be unique or an exception will be thrown.
(Inherited from GH_Chunk.) |
![]() | TryGetBoolean(String, Boolean) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetBoolean(String, Int32, Boolean) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetBoundingBox(String, GH_BoundingBox) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetBoundingBox(String, Int32, GH_BoundingBox) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetByte(String, Byte) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetByte(String, Int32, Byte) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDate(String, DateTime) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDate(String, Int32, DateTime) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDecimal(String, Decimal) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDecimal(String, Int32, Decimal) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDouble(String, Double) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDouble(String, Int32, Double) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingColor(String, Color) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingColor(String, Int32, Color) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingPoint(String, Point) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingPoint(String, Int32, Point) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingPointF(String, PointF) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingPointF(String, Int32, PointF) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingRectangle(String, Rectangle) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingRectangle(String, Int32, Rectangle) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingRectangleF(String, RectangleF) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingRectangleF(String, Int32, RectangleF) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingSize(String, Size) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingSize(String, Int32, Size) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingSizeF(String, SizeF) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetDrawingSizeF(String, Int32, SizeF) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetGuid(String, Guid) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetGuid(String, Int32, Guid) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInt32(String, Int32) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInt32(String, Int32, Int32) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInt64(String, Int64) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInt64(String, Int32, Int64) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInterval1D(String, GH_Interval1D) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInterval1D(String, Int32, GH_Interval1D) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInterval2D(String, GH_Interval2D) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetInterval2D(String, Int32, GH_Interval2D) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetLine(String, GH_Line) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetLine(String, Int32, GH_Line) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPlane(String, GH_Plane) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPlane(String, Int32, GH_Plane) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPoint2D(String, GH_Point2D) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPoint2D(String, Int32, GH_Point2D) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPoint3D(String, GH_Point3D) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPoint3D(String, Int32, GH_Point3D) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPoint4D(String, GH_Point4D) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetPoint4D(String, Int32, GH_Point4D) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetSingle(String, Single) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetSingle(String, Int32, Single) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetString(String, String) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetString(String, Int32, String) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetVersion(String, GH_Version) |
Gets the value of the item with the specified name.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | TryGetVersion(String, Int32, GH_Version) |
Gets the value of the item with the specified name and index.
Name comparison is not case-sensitive.
(Inherited from GH_Chunk.) |
![]() | Write(BinaryWriter) |
Write this chunk and all child chunks to a binary stream.
(Inherited from GH_Chunk.) |
![]() | Write(XmlWriter) |
Serialize this chunk into an Xml stream.
(Inherited from GH_Chunk.) |
Name | Description | |
---|---|---|
![]() | m_archive |
Pointer to the archive that owns the Root of the tree this chunk belongs to.
(Inherited from GH_Chunk.) |
![]() | m_chunks |
Dictionary of sub-chunks contained within this chunk.
(Inherited from GH_Chunk.) |
![]() | m_comments |
List of text comments. This list is automatically instantiated once the first comment is added.
(Inherited from GH_Chunk.) |
![]() | m_index |
Index of this chunk. This field is set only once, during construction.
A negative index indicates no index qualifier has been set.
(Inherited from GH_Chunk.) |
![]() | m_items |
The list of nodes contained within this chunk.
(Inherited from GH_Chunk.) |
![]() | m_name |
Name of this chunk. This field is set only once, during construction.
(Inherited from GH_Chunk.) |