Param_Centermark Methods |
The Param_Centermark type exposes the following members.
Name | Description | |
---|---|---|
AddRuntimeMessage |
Add a new message to this object. Valid message type flags are Warning and Error.
AddSource(IGH_Param) |
Append a new Source parameter to the end of the Sources list.
AddSource(IGH_Param, Int32) |
Insert a new Source parameter into the Sources list.
AppendMenuItems |
This function is called when a context menu is about to be displayed.
Override it to set custom items. GH_ActiveObject will already populate
the menu with default items, if you merely wish to insert object-specific
BakeGeometry(RhinoDoc, ListGuid) | ||
DestroyIconCache |
Call this method to erase the existing icon cache.
DrawViewportMeshes | ||
DrawViewportWires | ||
ExpirePreview |
Call this function when you suspect that the preview has expired for this object.
HtmlHelp_Source | (Overrides GH_DocumentObjectHtmlHelp_Source.) | |
InstantiateT | (Overrides GH_ParamTInstantiateT.) | |
Menu_AppendObjectName |
Appends the old-fashioned object name menu item. If you also want the
Menu_AppendPublish |
Appends the default item for publishing to RCP.
Menu_CreateMultilineTextEditItem |
This function returns a ToolstripMenuItem that embeds a multi-line textbox
for editing persistent data. Only call this method if you know that your
MovedBetweenDocuments |
This method will be called when an object is moved from one document to another.
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
OnPingDocument |
Raise the PingDocument Event on the toplevel object and try to find
OnSolutionExpired |
Raises the SolutionExpired event on the toplevel object.
PreferredCast | (Overrides GH_ParamTPreferredCast(Object).) | |
Preview_ComputeClippingBox |
This function can be used to iterate over all items in the Volatile data tree
and collect the union clipping box of all non-null items that implement
Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting,
Preview_DrawMeshes |
This function can be used to iterate over all items in the Volatile data tree
and call DrawViewportWires on each item that implements Preview.IGH_PreviewData.
This function requires a lot of TypeOf and DirectCasting,
Preview_DrawWires |
This function can be used to iterate over all items in the Volatile data tree
and call DrawViewportWires on each item that implements Preview.IGH_PreviewData.
This function requires a lot of TypeOf and DirectCasting,
Prompt_Plural | (Overrides GH_PersistentParamTPrompt_Plural(ListT).) | |
Prompt_Singular | (Overrides GH_PersistentParamTPrompt_Singular(T).) | |
RegisterRemoteIdsDespiteSources |
Call this method if you wish to register remote ids in the volatile
data despite having one or more sources. You should only need to do this if
RegisterRemoteIDsUtil |
Utility function which treats all data in the Volatile cache as IGH_GeometricGoo
and registers all referenced objects. Call this function from within RegisterRemoteIDs()
RelinkProxySources |
Attempt to replace all proxy sources with real sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
RemovedFromDocument |
This method will be called when an object is removed from a document.
RemoveEffects |
Remove all post-process effects. Note to implementors,
ReplaceSource(Guid, IGH_Param) |
Replace an existing source with a new one. If the old_source
ReplaceSource(IGH_Param, IGH_Param) |
Replace an existing source with a new one. If the old_source
SetPersistentData(T) |
Add a single item to the persistent data.
This method will record an undo event, raise the OnObjectChanged event
for PersistentData flags and place a call to ExpireSolution(False).
SetPersistentData(GH_StructureT) |
Assign a tree of items to the persistent data.
This method will erase any existing data,
record an undo event,
raise the OnObjectChanged event for PersistentData flags and
place a call to ExpireSolution(False).
SetPersistentData(IEnumerableT) |
Assign a list of items to the persistent data.
This method will erase any existing data,
record an undo event,
raise the OnObjectChanged event for PersistentData flags and
place a call to ExpireSolution(False).
ValuesChanged |
Override this method if you want to respond to changes to the value table.
WriteFull |
GH_InstanceDescription does not by default serialize all fields.
Use this function to write all fields to the archive.