Click or drag to resize

ObjectPropertiesPageEventArgs Class

[Missing <summary> documentation for "T:Rhino.UI.ObjectPropertiesPageEventArgs"]

Inheritance Hierarchy
SystemObject
  Rhino.UIObjectPropertiesPageEventArgs

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ObjectPropertiesPageEventArgs

The ObjectPropertiesPageEventArgs type exposes the following members.

Constructors
  NameDescription
Public methodObjectPropertiesPageEventArgs
Used by ObjectPropertiesPage to notify the page when updating, modifying or determining if the page should be included in the navigation bar
Top
Properties
  NameDescription
Public propertyDocRuntimeSerialNumber
Document containing the objects and views
Public propertyDocument
Document containing the objects and views
Public propertyEventRuntimeSerialNumber
Gets the runtime serial number.
Public propertyObjectCount
Public propertyObjects
Return a list of Rhino objects to be processed by this object properties page
Public propertyObjectTypes
Public propertyPage
The page sending these arguments
Public propertyView
Active view
Public propertyViewport
Active viewport
Top
Methods
  NameDescription
Public methodGetObjects(ObjectType)
Get selected objects that match a given filter
Public methodGetObjectsT
Get selected objects of a given type
Public methodIncludesObjectsType(ObjectType)
Public methodIncludesObjectsType(ObjectType, Boolean)
Public methodIncludesObjectsTypeT
Return true if any of the selected objects match the given type
Public methodIncludesObjectsTypeT(Boolean)
Return true if any of the selected objects match the given type
Top
See Also