Click or drag to resize

ObjectPropertiesPageEventArgsIncludesObjectsTypeT Method (Boolean)

Return true if any of the selected objects match the given type

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.7
Syntax
public bool IncludesObjectsType<T>(
	bool allMustMatch
)
where T : RhinoObject

Parameters

allMustMatch
Type: SystemBoolean
If true then every selected object must match the object type otherwise; only a single object has to be of the specified type

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.UI.ObjectPropertiesPageEventArgs.IncludesObjectsType``1(System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.UI.ObjectPropertiesPageEventArgs.IncludesObjectsType``1(System.Boolean)"]

See Also