Click or drag to resize

ObjectPropertiesPageEventArgsIncludesObjectsType Method (ObjectType, Boolean)

[Missing <summary> documentation for "M:Rhino.UI.ObjectPropertiesPageEventArgs.IncludesObjectsType(Rhino.DocObjects.ObjectType,System.Boolean)"]

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.7
Syntax
public bool IncludesObjectsType(
	ObjectType objectTypes,
	bool allMustMatch
)

Parameters

objectTypes
Type: Rhino.DocObjectsObjectType

[Missing <param name="objectTypes"/> documentation for "M:Rhino.UI.ObjectPropertiesPageEventArgs.IncludesObjectsType(Rhino.DocObjects.ObjectType,System.Boolean)"]

allMustMatch
Type: SystemBoolean
If true then every selected object must match the object type otherwise; only a single object has to be of the specified type

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.UI.ObjectPropertiesPageEventArgs.IncludesObjectsType(Rhino.DocObjects.ObjectType,System.Boolean)"]

See Also