Click or drag to resize

ObjectPropertiesPage Class

Base class used to add object property user interface panels
Inheritance Hierarchy
SystemObject
  Rhino.UIObjectPropertiesPage

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class ObjectPropertiesPage

The ObjectPropertiesPage type exposes the following members.

Constructors
  NameDescription
Protected methodObjectPropertiesPage
Initializes a new instance of the ObjectPropertiesPage class
Top
Properties
  NameDescription
Public propertyAllObjectsMustBeSupported
Returns false which only requires a single item of SupportedTypes to be selected. Override if you wish to change the above behavior.
Public propertyEnglishPageTitle
English string used to describe this page
Public propertyIcon Obsolete.
(OBSOLETE - Override PageIcon instead) Icon to display in the object properties tab control
Public propertyIndex
The page navigation control adds buttons in the order the pages are processed, override this method and return a sort index to move the button to the beginning of the list. By default this returns -1 which puts the button at the end of the list.
Public propertyLocalPageTitle
Localized page description string, returns the EnglishPageTitle by default.
Public propertyPageControl
The control that represents this page. Rhino Windows supports classes that implement the IWin32Windows interface, are derived from System.Windows.FrameworkElement or Eto.Forms.Control. Mac Rhino supports controls that are derived from NSview or Eto.Forms.Control.
Public propertyPageIconEmbeddedResourceString
Resource string for a embedded icon resource in the assembly containing the page instance. If this returns a valid resource and Rhino can load the icon the loaded icon will get used directly otherwise; the PageIcon method will get called.
Public propertyPageType
Override this and return the page you want to replace a specific object properties page.
Public propertySelectedObjects
Return a list of Rhino objects to be processed by this object properties page
Public propertySupportedTypes
Override to specify which objects this page supports
Public propertySupportsSubObjects
If your object properties page supports sub-object selection, you should override this method and return true. This is ignored for view pages. The default implementation returns false.
Top
Methods
  NameDescription
Public methodAnySelectedObjectT
Return true if any of the selected objects match the given type
Public methodAnySelectedObjectT(Boolean)
Return true if any of the selected objects match the given type
Public methodGetSelectedObjects(ObjectType)
Get selected objects that match a given filter
Public methodGetSelectedObjectsT
Get selected objects of a given type
Public methodInitializeControls Obsolete.
Called on the active page after the selected objects list has changed to notify the page to initialize its content to reflect the new object list.
Public methodModifyPage
Call this method when the page is ready to modify the selected objects list. Rhino will suspend UpdatePageNotfictaion, call the passed action then restore UpdatePageNotfictaion.
Public methodOnActivate
Called when this page is activated/deactivated.
Public methodOnCreateParent
Called when the parent container is initially created.
Public methodOnHelp
Called when the F1 key or help button is pressed, override to display plug-in specific help for this page.
Public methodOnSizeParent
Called when the parent containers client rectangle size has changed and the PageControl has been resized.
Public methodPageIcon
Icon to display in the object properties tab control. Will not get called if PageIconEmbeddedResourceString is overridden and provides a string for a successfully loaded icon resource.
Public methodRunScript(ObjectPropertiesPageEventArgs)
This method is called when scripting the Rhino Properties command and choosing this page.
Public methodRunScript(RhinoDoc, RhinoObject) Obsolete.
This method is called when scripting the Rhino Properties command and choosing this page.
Public methodShouldDisplay(ObjectPropertiesPageEventArgs)
Called when the selected objects list changes, return true if the object list contains one or more object the page can modify.
Public methodShouldDisplay(RhinoObject) Obsolete.
Called when the selected objects list changes, return true if the object list contains one or more object the page can modify.
Public methodUpdatePage
Called on the active page after the selected objects list has changed to notify the page to initialize its content to reflect the new object list.
Top
See Also