Click or drag to resize

ObjectPropertiesPage Methods

The ObjectPropertiesPage type exposes the following members.

Methods
  NameDescription
Public methodAnySelectedObjectT
Return true if any of the selected objects match the given type
Public methodAnySelectedObjectT(Boolean)
Return true if any of the selected objects match the given type
Public methodGetSelectedObjects(ObjectType)
Get selected objects that match a given filter
Public methodGetSelectedObjectsT
Get selected objects of a given type
Public methodInitializeControls Obsolete.
Called on the active page after the selected objects list has changed to notify the page to initialize its content to reflect the new object list.
Public methodModifyPage
Call this method when the page is ready to modify the selected objects list. Rhino will suspend UpdatePageNotfictaion, call the passed action then restore UpdatePageNotfictaion.
Public methodOnActivate
Called when this page is activated/deactivated.
Public methodOnCreateParent
Called when the parent container is initially created.
Public methodOnHelp
Called when the F1 key or help button is pressed, override to display plug-in specific help for this page.
Public methodOnSizeParent
Called when the parent containers client rectangle size has changed and the PageControl has been resized.
Public methodPageIcon
Icon to display in the object properties tab control. Will not get called if PageIconEmbeddedResourceString is overridden and provides a string for a successfully loaded icon resource.
Public methodRunScript(ObjectPropertiesPageEventArgs)
This method is called when scripting the Rhino Properties command and choosing this page.
Public methodRunScript(RhinoDoc, RhinoObject) Obsolete.
This method is called when scripting the Rhino Properties command and choosing this page.
Public methodShouldDisplay(ObjectPropertiesPageEventArgs)
Called when the selected objects list changes, return true if the object list contains one or more object the page can modify.
Public methodShouldDisplay(RhinoObject) Obsolete.
Called when the selected objects list changes, return true if the object list contains one or more object the page can modify.
Public methodUpdatePage
Called on the active page after the selected objects list has changed to notify the page to initialize its content to reflect the new object list.
Top
See Also