Click or drag to resize

ObjectPropertiesPage Properties

The ObjectPropertiesPage type exposes the following members.

Properties
  NameDescription
Public propertyAllObjectsMustBeSupported
Returns false which only requires a single item of SupportedTypes to be selected. Override if you wish to change the above behavior.
Public propertyEnglishPageTitle
English string used to describe this page
Public propertyIcon Obsolete.
(OBSOLETE - Override PageIcon instead) Icon to display in the object properties tab control
Public propertyIndex
The page navigation control adds buttons in the order the pages are processed, override this method and return a sort index to move the button to the beginning of the list. By default this returns -1 which puts the button at the end of the list.
Public propertyLocalPageTitle
Localized page description string, returns the EnglishPageTitle by default.
Public propertyPageControl
The control that represents this page. Rhino Windows supports classes that implement the IWin32Windows interface, are derived from System.Windows.FrameworkElement or Eto.Forms.Control. Mac Rhino supports controls that are derived from NSview or Eto.Forms.Control.
Public propertyPageIconEmbeddedResourceString
Resource string for a embedded icon resource in the assembly containing the page instance. If this returns a valid resource and Rhino can load the icon the loaded icon will get used directly otherwise; the PageIcon method will get called.
Public propertyPageType
Override this and return the page you want to replace a specific object properties page.
Public propertySelectedObjects
Return a list of Rhino objects to be processed by this object properties page
Public propertySupportedTypes
Override to specify which objects this page supports
Public propertySupportsSubObjects
If your object properties page supports sub-object selection, you should override this method and return true. This is ignored for view pages. The default implementation returns false.
Top
See Also