Click or drag to resize

FieldDictionary Class

Dictionary containing RenderContent data fields. Add fields to this dictionary in your derived RenderContent classes constructor. Get field values using the TryGet[data type]() methods and set them using the Set() method.
Inheritance Hierarchy
SystemObject
  Rhino.Render.FieldsFieldDictionary

Namespace:  Rhino.Render.Fields
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class FieldDictionary : IEnumerable

The FieldDictionary type exposes the following members.

Methods
  NameDescription
Public methodAdd(String, Color4f)
Add a new Color4fField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Point2d)
Add a new Point2dField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Point3d)
Add a new Point3dField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Point4d)
Add a new Point4dField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Transform)
Add a new TransformField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Vector2d)
Add a new Vector2dField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Vector3d)
Add a new Vector3dField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Boolean)
Add a new BoolField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Byte)
AddField a new ByteArrayField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, DateTime)
Add a new DateTimeField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Double)
AddField a new DoubleField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Color)
Add a new Color4fField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Guid)
Add a new GuidField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Int32)
Add a new IntField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Single)
Add a new FloatField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, String)
Add a new StringField to the dictionary. This will be a data only field and not show up in the content browsers.
Public methodAdd(String, Color4f, String)
Add a new Color4fField to the dictionary.
Public methodAdd(String, Point2d, String)
Add a new Point2dField to the dictionary.
Public methodAdd(String, Point3d, String)
Add a new Point3dField to the dictionary.
Public methodAdd(String, Point4d, String)
Add a new Point4dField to the dictionary.
Public methodAdd(String, Transform, String)
Add a new TransformField to the dictionary.
Public methodAdd(String, Vector2d, String)
Add a new Vector2dField to the dictionary.
Public methodAdd(String, Vector3d, String)
Add a new Vector3dField to the dictionary.
Public methodAdd(String, Boolean, String)
Add a new BoolField to the dictionary.
Public methodAdd(String, DateTime, String)
Add a new DateTimeField to the dictionary.
Public methodAdd(String, Double, String)
Add a new DoubleField to the dictionary.
Public methodAdd(String, Color, String)
Add a new Color4fField to the dictionary.
Public methodAdd(String, Guid, String)
Add a new GuidField to the dictionary.
Public methodAdd(String, Int32, String)
Add a new IntField to the dictionary.
Public methodAdd(String, Single, String)
AddField a new FloatField to the dictionary.
Public methodAdd(String, String, Int32)
Add a new NullField to the dictionary.
Public methodAdd(String, String, String)
Add a new StringField to the dictionary.
Public methodAdd(String, Color4f, String, Int32)
Add a new Color4fField to the dictionary.
Public methodAdd(String, Point2d, String, Int32)
Add a new Point2dField to the dictionary.
Public methodAdd(String, Point3d, String, Int32)
Add a new Point3dField to the dictionary.
Public methodAdd(String, Point4d, String, Int32)
Add a new Point4dField to the dictionary.
Public methodAdd(String, Transform, String, Int32)
Add a new TransformField to the dictionary.
Public methodAdd(String, Vector2d, String, Int32)
Add a new Vector2dField to the dictionary.
Public methodAdd(String, Vector3d, String, Int32)
Add a new Vector3dField to the dictionary.
Public methodAdd(String, Boolean, String, Int32)
Add a new BoolField to the dictionary.
Public methodAdd(String, DateTime, String, Int32)
Add a new DateTimeField to the dictionary.
Public methodAdd(String, Double, String, Int32)
Add a new DoubleField to the dictionary.
Public methodAdd(String, Guid, String, Int32)
Add a new GuidField to the dictionary.
Public methodAdd(String, Int32, String, Int32)
Add a new IntField to the dictionary.
Public methodAdd(String, Single, String, Int32)
AddField a new FloatField to the dictionary.
Public methodAdd(String, String, String, Int32)
Add a new StringField to the dictionary.
Public methodAddFilename
Add a new StringField to the dictionary which will reference a filename. A file watcher will automatically be attached to the referenced file, and the content will be considered changed when the file is changed on disk.
Public methodAddTextured(String, String)
Add a new NullField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Color4f, String) Obsolete.
Public methodAddTextured(String, Point2d, String)
Add a new Point2dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point3d, String)
Add a new Point3dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point4d, String)
Add a new Point4dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Transform, String)
Add a new TransformField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Vector2d, String)
Add a new Vector2dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Vector3d, String)
Add a new Vector3dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Boolean, String)
Add a new BoolField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, DateTime, String)
Add a new DateTimeField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Double, String)
Add a new DoubleField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Color, String)
Add a new Color4fField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Guid, String)
Add a new GuidField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Int32, String)
Add a new IntField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Single, String)
Add a new FloatField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, String, Boolean)
Add a new NullField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, String, String)
Add a new StringField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Color4f, String, Boolean)
Add a new Color4fField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point2d, String, Boolean)
Add a new Point2dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point3d, String, Boolean)
Add a new Point3dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point4d, String, Boolean)
Add a new Point4dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Transform, String, Boolean)
Add a new TransformField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Vector2d, String, Boolean)
Add a new Vector2dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Vector3d, String, Boolean)
Add a new Vector3dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Boolean, String, Boolean)
Add a new BoolField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, DateTime, String, Boolean)
Add a new DateTimeField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Double, String, Boolean)
Add a new DoubleField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Color, String, Boolean)
Add a new Color4fField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Guid, String, Boolean)
Add a new GuidField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Int32, String, Boolean)
Add a new IntField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Single, String, Boolean)
Add a new FloatField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, String, Boolean, Int32)
Add a new NullField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, String, String, Boolean)
Add a new StringField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Color4f, String, Boolean, Int32)
Add a new Color4fField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point2d, String, Boolean, Int32)
Add a new Point2dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point3d, String, Boolean, Int32)
Add a new Point3dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Point4d, String, Boolean, Int32)
Add a new Point4dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Transform, String, Boolean, Int32)
Add a new TransformField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Vector2d, String, Boolean, Int32)
Add a new Vector2dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Vector3d, String, Boolean, Int32)
Add a new Vector3dField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Boolean, String, Boolean, Int32)
Add a new BoolField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, DateTime, String, Boolean, Int32)
Add a new DateTimeField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Double, String, Boolean, Int32)
Add a new DoubleField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Guid, String, Boolean, Int32)
Add a new GuidField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Int32, String, Boolean, Int32)
Add a new IntField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, Single, String, Boolean, Int32)
Add a new FloatField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodAddTextured(String, String, String, Boolean, Int32)
Add a new StringField to the dictionary. This overload will cause the field to be tagged as "textured" so that the texturing UI will appear in automatic UIs.
Public methodContainsField
Call this method to determine if a this FieldsList contains a field with the specified field name.
Public methodGetEnumerator
Public methodGetField
Call this method to get the field with the specified name.
Public methodRemoveField
Public methodSet(String, Color4f)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Point2d)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Point3d)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Point4d)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Transform)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Vector2d)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Vector3d)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Boolean)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Byte)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, DateTime)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Double)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Color)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Guid)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Int32)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, Single)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodSet(String, String)
Set the field value and send the appropriate change notification to the render SDK. Will throw a InvalidOperationException exception if the key name is not valid.
Public methodTryGetValue(String, Color4f)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Point2d)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Point3d)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Point4d)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Transform)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Vector2d)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Vector3d)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Boolean)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Byte)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, DateTime)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Double)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Color)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Guid)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Int32)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, Single)
Find a field with the specified key and get its value if found.
Public methodTryGetValue(String, String)
Find a field with the specified key and get its value if found.
Public methodTryGetValueT(String, T)
Parametrized version of TryGetValue.
Top
Examples
[System.Runtime.InteropServices.Guid("ABE4059B-9BD7-451C-91B2-67C2F188860A")] public class CustomMaterial : RenderMaterial { public override string TypeName { get { return "CSharp Custom Material"; } } public override string TypeDescription { get { return "My first custom .NET material"; } } public CustomMaterial() { Fields.AddField("bool", false, "Yes/No"); Fields.AddField("color", Rhino.Display.Color4f.White, "Color"); } }
See Also