Click or drag to resize

Field Class

Generic data fields used to add publicly accessible properties to RenderContent.FieldDictionary. These should be created by calling a FieldDictaionary.Add() method on a Render content object. These are allocated after the RenderContent object's C++ object is created and added to the underlying C++ objects content dictionary, who ever allocates a field is responsible for deleting it so these objects clean up the C++ pointers when they are disposed of.
Inheritance Hierarchy
SystemObject
  Rhino.Render.FieldsField
    More...

Namespace:  Rhino.Render.Fields
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class Field

The Field type exposes the following members.

Constructors
  NameDescription
Protected methodField(RenderContent, IntPtr)
Initializes a new instance of the Field class
Protected methodField(RenderContent, String)
Initializes a new instance of the Field class
Protected methodField(RenderContent, String, String, Object, Boolean) Obsolete.
Initializes a new instance of the Field class
Protected methodField(RenderContent, String, String, Object, Boolean, Boolean)
Initializes a new instance of the Field class
Protected methodField(RenderContent, String, String, Object, Boolean, Boolean, Int32)
Initializes a new instance of the Field class
Top
Properties
  NameDescription
Public propertyIsHiddenInAutoUI
When fields are used by the automatic UI, they can be hidden from it by calling this method.
Public propertyName
Field name value string passed to the constructor.
Public propertyTag
Gets or sets an object that contains data to associate with the field.
Public propertyTextureAmountMax
Set Max value for Texture amount
Public propertyTextureAmountMin
Set Min value for Texture amount
Public propertyUseTextureAmount
True if 'texture amount' is in use, otherwise false. The 'texture amount' is represented as a numeric stepper in the UI. If true, then the stepper is shown. If false, then the stepper is hidden.
Public propertyUseTextureOn
True if 'texture on' is in use, otherwise false. In the UI 'texture on' is represented as a checkbox. If true then the checbox is shown. If false then the checkbox is not shown.
Top
Methods
  NameDescription
Protected methodCreateCppPointer
Public methodGetValueT
Parametrized version of GetValue calling appropriate ValueAs* methods.
Protected methodValueAsBool
Return field value as a bool.
Protected methodValueAsByteArray
Return field as a byte array.
Protected methodValueAsColor4f
Return field as a Rhino.Display.Color4f color value.
Protected methodValueAsDateTime
Return field as a DateTime value.
Protected methodValueAsDouble
Return field value as a double precision number.
Protected methodValueAsFloat
Return field value as floating point number.
Protected methodValueAsGuid
Return field value as Guid.
Protected methodValueAsInt
Return field value as integer.
Public methodValueAsObject
Protected methodValueAsPoint2d
Return field as a Rhino.Geometry.Point2d color value.
Protected methodValueAsPoint3d
Return field as a Rhino.Geometry.Point3d color value.
Protected methodValueAsPoint4d
Return field as a Rhino.Geometry.Point4d color value.
Protected methodValueAsString
Get field value as a string.
Protected methodValueAsTransform
Return field as a Rhino.Geometry.Transform color value.
Protected methodValueAsVector2d
Return field as a Rhino.Geometry.Vector2d color value.
Protected methodValueAsVector3d
Return field as a Rhino.Geometry.Vector3d color value.
Top
See Also
Inheritance Hierarchy
SystemObject
  Rhino.Render.FieldsField
    Rhino.Render.FieldsBoolField
    Rhino.Render.FieldsByteArrayField
    Rhino.Render.FieldsColor4fField
    Rhino.Render.FieldsDateTimeField
    Rhino.Render.FieldsDoubleField
    Rhino.Render.FieldsFloatField
    Rhino.Render.FieldsGuidField
    Rhino.Render.FieldsIntField
    Rhino.Render.FieldsNullField
    Rhino.Render.FieldsPoint2dField
    Rhino.Render.FieldsPoint3dField
    Rhino.Render.FieldsPoint4dField
    Rhino.Render.FieldsStringField
    Rhino.Render.FieldsTransformField
    Rhino.Render.FieldsVector2dField
    Rhino.Render.FieldsVector3dField