GuidField Class |
Namespace: Rhino.Render.Fields
The GuidField type exposes the following members.
Name | Description | |
---|---|---|
IsHiddenInAutoUI |
When fields are used by the automatic UI, they can be hidden from it by calling this method.
(Inherited from Field.) | |
Name |
Field name value string passed to the constructor.
(Inherited from Field.) | |
Tag |
Gets or sets an object that contains data to associate with the field.
(Inherited from Field.) | |
TextureAmountMax |
Set Max value for Texture amount
(Inherited from Field.) | |
TextureAmountMin |
Set Min value for Texture amount
(Inherited from Field.) | |
UseTextureAmount |
True if 'texture amount' is in use, otherwise false. The 'texture amount' is represented
as a numeric stepper in the UI. If true, then the stepper is shown. If false, then the
stepper is hidden.
(Inherited from Field.) | |
UseTextureOn |
True if 'texture on' is in use, otherwise false. In the UI 'texture on' is represented
as a checkbox. If true then the checbox is shown. If false then the checkbox is not shown.
(Inherited from Field.) | |
Value |
Gets or sets the field value
|
Name | Description | |
---|---|---|
CreateCppPointer | (Inherited from Field.) | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
GetValueT |
Parametrized version of GetValue calling appropriate ValueAs* methods.
(Inherited from Field.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
ValueAsBool |
Return field value as a bool.
(Inherited from Field.) | |
ValueAsByteArray |
Return field as a byte array.
(Inherited from Field.) | |
ValueAsColor4f |
Return field as a Rhino.Display.Color4f color value.
(Inherited from Field.) | |
ValueAsDateTime |
Return field as a DateTime value.
(Inherited from Field.) | |
ValueAsDouble |
Return field value as a double precision number.
(Inherited from Field.) | |
ValueAsFloat |
Return field value as floating point number.
(Inherited from Field.) | |
ValueAsGuid |
Return field value as Guid.
(Inherited from Field.) | |
ValueAsInt |
Return field value as integer.
(Inherited from Field.) | |
ValueAsObject | (Overrides FieldValueAsObject.) | |
ValueAsPoint2d |
Return field as a Rhino.Geometry.Point2d color value.
(Inherited from Field.) | |
ValueAsPoint3d |
Return field as a Rhino.Geometry.Point3d color value.
(Inherited from Field.) | |
ValueAsPoint4d |
Return field as a Rhino.Geometry.Point4d color value.
(Inherited from Field.) | |
ValueAsString |
Get field value as a string.
(Inherited from Field.) | |
ValueAsTransform |
Return field as a Rhino.Geometry.Transform color value.
(Inherited from Field.) | |
ValueAsVector2d |
Return field as a Rhino.Geometry.Vector2d color value.
(Inherited from Field.) | |
ValueAsVector3d |
Return field as a Rhino.Geometry.Vector3d color value.
(Inherited from Field.) |