Click or drag to resize

Field Methods

The Field type exposes the following members.

Methods
  NameDescription
Protected methodCreateCppPointer
Public methodGetValueT
Parametrized version of GetValue calling appropriate ValueAs* methods.
Protected methodValueAsBool
Return field value as a bool.
Protected methodValueAsByteArray
Return field as a byte array.
Protected methodValueAsColor4f
Return field as a Rhino.Display.Color4f color value.
Protected methodValueAsDateTime
Return field as a DateTime value.
Protected methodValueAsDouble
Return field value as a double precision number.
Protected methodValueAsFloat
Return field value as floating point number.
Protected methodValueAsGuid
Return field value as Guid.
Protected methodValueAsInt
Return field value as integer.
Public methodValueAsObject
Protected methodValueAsPoint2d
Return field as a Rhino.Geometry.Point2d color value.
Protected methodValueAsPoint3d
Return field as a Rhino.Geometry.Point3d color value.
Protected methodValueAsPoint4d
Return field as a Rhino.Geometry.Point4d color value.
Protected methodValueAsString
Get field value as a string.
Protected methodValueAsTransform
Return field as a Rhino.Geometry.Transform color value.
Protected methodValueAsVector2d
Return field as a Rhino.Geometry.Vector2d color value.
Protected methodValueAsVector3d
Return field as a Rhino.Geometry.Vector3d color value.
Top
See Also