Click or drag to resize

RhinoGet Class

Base class for GetObject, GetPoint, GetSphere, etc. You will never directly create a RhinoGet but you will use its member functions after calling GetObject::GetObjects(), GetPoint::GetPoint(), and so on. Provides tools to set command prompt, set command options, and specify if the "get" can optionally accept numbers, nothing (pressing enter), and undo.
Inheritance Hierarchy
SystemObject
  Rhino.InputRhinoGet

Namespace:  Rhino.Input
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class RhinoGet

The RhinoGet type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAllBitmapFileTypes
Top
Methods
  NameDescription
Public methodStatic memberGet2dRectangle
Gets a rectangle in view window coordinates.
Public methodStatic memberGetAngle
Allows user to interactively pick an angle
Public methodStatic memberGetArc
Public methodStatic memberGetBool
Easy to use Boolean getter.
Public methodStatic memberGetBox(Box)
Asks the user to select a Box in the viewport.
Public methodStatic memberGetBox(Box, GetBoxMode, Point3d, String, String, String)
Asks the user to select a Box in the viewport.
Public methodStatic memberGetBoxWithCounts
Gets a 3d box with prompts for counts in X, Y and Z directions.
Public methodStatic memberGetCircle
Public methodStatic memberGetColor
Easy to use color getter.
Public methodStatic memberCode exampleGetFileName(GetFileNameMode, String, String, Object)
Public methodStatic memberCode exampleGetFileName(GetFileNameMode, String, String, Object, RhinoGetBitmapFileTypes)
Public methodStatic memberGetFileNameScripted
Public methodStatic memberGetGrip
Public methodStatic memberGetGrips
Public methodStatic memberGetHelix
Public methodStatic memberGetInteger(String, Boolean, Int32)
Easy to use number getter.
Public methodStatic memberGetInteger(String, Boolean, Int32, Int32, Int32)
Easy to use number getter.
Public methodStatic memberGetLine
Public methodStatic memberCode exampleGetLinearDimension
Public methodStatic memberGetMeshParameters
Asks the user to specify meshing parameters.
Public methodStatic memberCode exampleGetMultipleObjects(String, Boolean, ObjectType, ObjRef)
Easy to use object getter for getting multiple objects.
Public methodStatic memberGetMultipleObjects(String, Boolean, GetObjectGeometryFilter, ObjRef)
Easy to use object getter for getting multiple objects.
Public methodStatic memberCode exampleGetNumber(String, Boolean, Double)
Easy to use number getter.
Public methodStatic memberCode exampleGetNumber(String, Boolean, Double, Double, Double)
Easy to use number getter.
Public methodStatic memberCode exampleGetOneObject(String, Boolean, ObjectType, ObjRef)
Easy to use object getter.
Public methodStatic memberGetOneObject(String, Boolean, GetObjectGeometryFilter, ObjRef)
Easy to use object getter.
Public methodStatic memberCode exampleGetPlane
Gets an oriented infinite plane.
Public methodStatic memberCode exampleGetPoint
Gets a point coordinate from the document.
Public methodStatic memberGetPointOnMesh(Guid, String, Boolean, Point3d) Obsolete.
Gets a point constrained to an existing mesh in the document.
Public methodStatic memberGetPointOnMesh(MeshObject, String, Boolean, Point3d) Obsolete.
Gets a point constrained to an existing mesh in the document.
Public methodStatic memberGetPointOnMesh(RhinoDoc, MeshObject, String, Boolean, Point3d)
Gets a point constrained to an existing mesh in the document.
Public methodStatic memberGetPointOnMesh(RhinoDoc, Guid, String, Boolean, Point3d)
Gets a point constrained to an existing mesh in the document.
Public methodStatic memberGetPolygon(Int32, Boolean, Polyline)
Public methodStatic memberGetPolygon(Boolean, Int32, Boolean, Polyline)
Public methodStatic memberGetPolyline
Public methodStatic memberGetPrintWindow
Public methodStatic memberCode exampleGetRectangle(Point3d)
Gets a 3d rectangle.
Public methodStatic memberGetRectangle(String, Point3d)
Gets a 3d rectangle.
Public methodStatic memberGetRectangle(GetBoxMode, Point3d, IEnumerableString, Point3d)
Gets a 3d rectangle made up of four points.
Public methodStatic memberGetRectangleWithCounts
Gets a 3d rectangle with prompts for counts in X and Y directions.
Public methodStatic memberGetSpiral
Public methodStatic memberCode exampleGetString
Easy to use string getter.
Public methodStatic memberCode exampleGetView
Allows the user to interactively pick a viewport.
Public methodStatic memberInGet
Returns true if the document is current in a "Get" operation.
Public methodStatic memberInGetObject
Returns true if currently in a GetObject.GetObjects()
Public methodStatic memberInGetPoint
Returns true if currently in a GetPoint.Get()
Public methodStatic memberStringToCommandOptionName(String)
Convert some arbitrary string value to a valid command option name removing any invalid characters.
Public methodStatic memberStringToCommandOptionName(String, String)
Convert some arbitrary string value to a valid command option name removing any invalid characters.
Top
See Also