Click or drag to resize

RhinoGetGetPointOnMesh Method (RhinoDoc, MeshObject, String, Boolean, Point3d)

Gets a point constrained to an existing mesh in the document.

Namespace:  Rhino.Input
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.6
Syntax
public static Result GetPointOnMesh(
	RhinoDoc doc,
	MeshObject meshObject,
	string prompt,
	bool acceptNothing,
	out Point3d point
)

Parameters

doc
Type: RhinoRhinoDoc
The Rhino document
meshObject
Type: Rhino.DocObjectsMeshObject
An mesh object in the document.
prompt
Type: SystemString
Text prompt.
acceptNothing
Type: SystemBoolean
true if nothing else should be accepted.
point
Type: Rhino.GeometryPoint3d
A point value will be assigned to this out parameter during this call.

Return Value

Type: Result
The command result based on user choice.
See Also