Click or drag to resize

Rhino.Input Namespace

Classes related to getting user input for things like points, objects, and numbers

Classes related to getting user input for things like points, objects, and numbers

Classes
  ClassDescription
Public classRhinoGet
Base class for GetObject, GetPoint, GetSphere, etc. You will never directly create a RhinoGet but you will use its member functions after calling GetObject::GetObjects(), GetPoint::GetPoint(), and so on. Provides tools to set command prompt, set command options, and specify if the "get" can optionally accept numbers, nothing (pressing enter), and undo.
Public classStringParser
Parse strings to numbers, distances and angles
Public classStringParserSettings
Parameters for parsing strings
Enumerations
  EnumerationDescription
Public enumerationGetBoxMode
Enumerates all Box getter modes.
Public enumerationGetResult
Possible results from GetObject.Get(), GetPoint.Get(), etc...
Public enumerationRhinoGetBitmapFileTypes