Click or drag to resize

StringParserSettings Class

Parameters for parsing strings
Inheritance Hierarchy
SystemObject
  Rhino.InputStringParserSettings

Namespace:  Rhino.Input
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class StringParserSettings : IDisposable

The StringParserSettings type exposes the following members.

Constructors
  NameDescription
Public methodStringParserSettings
Initializes a new instance of the StringParserSettings class
Top
Properties
  NameDescription
Public propertyDefaultAngleUnitSystem
Public propertyDefaultLengthUnitSystem
Public propertyStatic memberDefaultParseSettings
- The default settings parse just about everything in a reasonable way. - Any angle values with unspecified units will be treated as radians. Angles without units can be encountered while parsing formulas, lengths and points and need to be thoughtfully considered in most parsing situations.
Public propertyParseAddition
Public propertyParseArcDegreesMinutesSeconds
Public propertyParseArithmeticExpression
Public propertyParseCommaAsDecimalPoint
Public propertyParseCommaAsDigitSeparator
Public propertyParseDAsExponentInScientificENotation
Public propertyParseDivision
Public propertyParseExplicitFormulaExpression
Public propertyParseFeetInches
Public propertyParseFullStopAsDecimalPoint
Public propertyParseFullStopAsDigitSeparator
Public propertyParseHyphenAsNumberDash
Public propertyParseHyphenMinusAsNumberDash
Public propertyParseIntegerDashFraction
Public propertyParseLeadingWhiteSpace
Public propertyParseMathFunctions
Public propertyParseMultiplication
Public propertyParsePairedParentheses
Public propertyParsePi
Public propertyParseRationalNumber
Public propertyParseScientificENotation
Public propertyStatic memberParseSettingsDegrees
- The default settings parse just about everything in a reasonable way. - Any angle values with unspecified units will be treated as degrees.Angles without units can be encountered while parsing formulas, lengths and points and need to be thoughtfully considered in most parsing situations.
Public propertyStatic memberParseSettingsDoubleNumber
- The double number settings parse and optional unary + or unary - and then parse a number that can be integer, decimal, or scientific e notation.
Public propertyStatic memberParseSettingsEmpty
- ON_ParseSetting::FalseSettings has all parsing options set to false. - A common use of ON_ParseSettings FalseSettings is to initialize ON_ParseSettings classes that are used to report what happened during parsing.Any parsing results value set to true after parsing indicates that type of parsing occurred.
Public propertyStatic memberParseSettingsIntegerNumber
- The integer settings parse and optional unary + or unary - and then parses one or more digits.Parsing stops after the last digit.
Public propertyStatic memberParseSettingsRadians
- The default settings parse just about everything in a reasonable way. - Any angle values with unspecified units will be treated as radians.Angles without units can be encountered while parsing formulas, lengths and points and need to be thoughtfully considered in most parsing situations.
Public propertyStatic memberParseSettingsRationalNumber
- The rational number settings parse and optional unary + or unary - and then parse one or more digits.If a rational number fraction bar follows the last digit in the numerator, then it is parsed and an integer denominator is parsed.The denominator cannot have a unary + or - preceding the digits.Parsing stops after the last digit in the denominator.
Public propertyStatic memberParseSettingsRealNumber
- The real number settings parse and optional unary + or unary - and then parse a number that can be integer, decimal, scientific e notation or pi.
Public propertyParseSignificandDigitSeparators
Public propertyParseSignificandFractionalPart
Public propertyParseSignificandIntegerPart
Public propertyParseSpaceAsDigitSeparator
Public propertyParseSubtraction
Public propertyParseSurveyorsNotation
Public propertyParseUnaryMinus
Public propertyParseUnaryPlus
Public propertyPreferedLocaleId
Top
Methods
  NameDescription
Public methodDispose
Releases all resources used by the StringParserSettings
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the StringParserSettings and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodSetAllExpressionSettingsToFalse
Public methodSetAllFieldsToFalse
Top
See Also