Click or drag to resize

RhinoGetGetInteger Method (String, Boolean, Int32, Int32, Int32)

Easy to use number getter.

Namespace:  Rhino.Input
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Result GetInteger(
	string prompt,
	bool acceptNothing,
	ref int outputNumber,
	int lowerLimit,
	int upperLimit
)

Parameters

prompt
Type: SystemString
The command prompt.
acceptNothing
Type: SystemBoolean
If true, the user can press enter.
outputNumber
Type: SystemInt32
default number is set to this value and number value returned here.
lowerLimit
Type: SystemInt32
The minimum allowed value.
upperLimit
Type: SystemInt32
The maximum allowed value.

Return Value

Type: Result
Commands.Result.Success - got number Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel number getting.
See Also