Click or drag to resize

RhinoGetGetBox Method (Box, GetBoxMode, Point3d, String, String, String)

Asks the user to select a Box in the viewport.

Namespace:  Rhino.Input
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static Result GetBox(
	out Box box,
	GetBoxMode mode,
	Point3d basePoint,
	string prompt1,
	string prompt2,
	string prompt3
)

Parameters

box
Type: Rhino.GeometryBox
If the result is Success, this parameter will be filled out.
mode
Type: Rhino.InputGetBoxMode
A particular "get box" mode, or All.
basePoint
Type: Rhino.GeometryPoint3d
Optional base point. Supply Point3d.Unset if you don't want to use this.
prompt1
Type: SystemString
Optional first prompt. Supply null to use the default prompt.
prompt2
Type: SystemString
Optional second prompt. Supply null to use the default prompt.
prompt3
Type: SystemString
Optional third prompt. Supply null to use the default prompt.

Return Value

Type: Result
Commands.Result.Success if successful.
See Also